Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Position of private window

  • 6 replies
  • 1 has this problem
  • 25 views
  • Last reply by cfcentaurea

more options

To avoid neck strain, I have my browser window set to fill only the lower part of my screen - not maximized.

When I open regular FF, it opens the window to the desired size & position. But when I then open a private window, it opens in the right size, but at the top of the screen, and I have to move it down every time - which strains my neck. Is there any setting I can change so that the private window will open in the same size & position as the regular window?

To avoid neck strain, I have my browser window set to fill only the lower part of my screen - not maximized. When I open regular FF, it opens the window to the desired size & position. But when I then open a private window, it opens in the right size, but at the top of the screen, and I have to move it down every time - which strains my neck. Is there any setting I can change so that the private window will open in the same size & position as the regular window?

Chosen solution

Okay, I updated the Add-on. It now has a toolbar button that lets you set the current window position and size as the one you want the add-on to use for future new windows.

https://addons.mozilla.org/firefox/addon/change-maximized-to-resizable/

During the installation, you will get a drop-down panel at the left and a second one at the right. In the second one, check the box and click Okay to enable the add-on to move/resize private windows:

After positioning and sizing the window to your liking, click the add-on's toolbar button and choose the Set options and then click Save Changes. Test with a new window to see whether it works.

Since you will hardly ever need the toolbar button, you can move it to the overflow menu or remove it from the toolbar after that. Either:

  • right-click > Pin to Overflow Menu
  • right-click > Remove from Toolbar

Does it help?

Read this answer in context 👍 1

All Replies (6)

more options

.......

Modified by jonzn4SUSE

Helpful?

more options

Thanks, but I don't see any add-ons that address this specific issue.

Helpful?

more options

I realize this first suggestion is off topic, but it sounds like your monitor is too high relative to your seating position. It would be better if your eyeline matches the top of the monitor rather than the middle when your neck is in a comfortable position. Maybe a seat cushion or a table/desk adjustment could help you use your entire screen, which would benefit browsers and other programs as well. Not sure whether that is an option for you.

Regarding add-ons, I was planning to eventually add something like that to one of mine. I'll try to do it this weekend.

Helpful?

more options

Hi jscher2000! I've adjusted things as much as I can without buying a new desk and monitor, which is not an option at this time. Making the seat high enough to ease the strain on my neck increases lower back pain. I really can see no reason why the private window shouldn't open in the same position as the regular window. I'm looking forward to your add-on. Thanks!

Helpful?

more options

Chosen Solution

Okay, I updated the Add-on. It now has a toolbar button that lets you set the current window position and size as the one you want the add-on to use for future new windows.

https://addons.mozilla.org/firefox/addon/change-maximized-to-resizable/

During the installation, you will get a drop-down panel at the left and a second one at the right. In the second one, check the box and click Okay to enable the add-on to move/resize private windows:

After positioning and sizing the window to your liking, click the add-on's toolbar button and choose the Set options and then click Save Changes. Test with a new window to see whether it works.

Since you will hardly ever need the toolbar button, you can move it to the overflow menu or remove it from the toolbar after that. Either:

  • right-click > Pin to Overflow Menu
  • right-click > Remove from Toolbar

Does it help?

Helpful?

more options

Beautiful - works like a charm! Thank you so much!  :-D

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.