Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Netflix and Youtube Videos not playing

  • 4 replies
  • 1 has this problem
  • 14 views
  • Last reply by FredMcD

more options

For some reason I can't watch any of the licensed content on youtube I purchased, and I cannot watch anything on netflix. Both problems appeared at the same time so I thought they might be related. I have disabled hardware acceleration with no effect. I have cleared history and deleted cookies. I have also disabled my vpn, but none of it works.

Anyone else had this problem? Netflix says "browser not supported" and youtube says "problems showing licensed content."

Chosen solution

Your User Agent shows: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0/AYocYrYF-01

Note the junk at the end.


https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/


Do you have enabled "Resist Fingerprinting" if you check ‘’’Resist Fingerprinting’’’ on the ‘’’about:config’’’ page as this affects the user agent?


’’’Avast AntiTrack’’’ is also known to cause this issue.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Your User Agent shows: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0/AYocYrYF-01

Note the junk at the end.


https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/


Do you have enabled "Resist Fingerprinting" if you check ‘’’Resist Fingerprinting’’’ on the ‘’’about:config’’’ page as this affects the user agent?


’’’Avast AntiTrack’’’ is also known to cause this issue.

Helpful?

more options

Make sure you have the latest Widevine version (4.10.2391.0).

You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests in the Browser Console if this doesn't work.

Helpful?

more options

Thank you both! It looks like it was caused mostly by my Avast security software, creating not only the 'user agent' problem but also the widevine was out of date. I removed avast anti track and refreshed Firefox and that fixed the issue.

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.