Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox security warning when downloading PDFs: How do I disable this?

  • 22 replies
  • 1 has this problem
  • 558 views
  • Last reply by Kiki

more options

Hi. Starting somewhat recently, Firefox has been getting in the way of me downloading certain PDFs which I know to be fine but which it thinks are insecure or a security hazard. I'd like to disable this security "feature" permanently. How can I do this? Thanks!

Hi. Starting somewhat recently, Firefox has been getting in the way of me downloading certain PDFs which I know to be fine but which it thinks are insecure or a security hazard. I'd like to disable this security "feature" permanently. How can I do this? Thanks!

Chosen solution

Hi Kiki. Thanks again for the response.

Since I personally can't stand the thought that a solution can't be found on this website, I will report that I've found the solution at:

https://www.techradar.com/news/firefox-is-ready-to-protect-against-potentially-dangerous-downloads

Simply, one goes to about:config and sets block_download_insecure to false. Easy.

Folks who are considering doing that, however, should know that they're taking the guard off the table saw. It *can* now hurt you, so do this disabling at your own considerable risk. The goals of this protection are noble and worth pursuing, but there are still issues.

While I struggled with this, I discovered that most of the issues I encountered arose because of mis-configured websites that sent downloads over unsecured channels. Webmasters really need to get their acts together to fix this silly ridiculousness. It opens everyone up to a security issue which is potentially VERY damaging.

Thank you again, Kiki and others, for bothering to respond.

Read this answer in context 👍 1

All Replies (2)

more options

Hi Andmagdo,

I tried that earlier, actually, and found it didn't work for me, hence the about:config solution. I'm not sure why that's the case. Thanks for the reply.

more options
Thank you again, Kiki and others, for bothering to respond.

No problem. Thanks also for andmagdo for the additional trick for this issue.

  1. 1
  2. 2