X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want to disable firefox 19 pdf viewer and use foxit in the browser without downloading.

Posted

I tried the two methods I've heard so far to disable the new firefox 19 pdf viewr: -in about:config set pdfjs.disable to true -options>Applications>set pdf view application

The trouble: when I set the viewing application for pdf to Foxit, firefox automatically downloads the pdf to open it in the separate application. Up until firefox 19, the Foxit reader application would open in the browser. Since Foxit does not have a firefox add-on, how do I disable the firefox 19 pdf viewer and use Foxit Reader to open pdfs as a new tab in the browser?

Chosen solution

In order to render content in a Firefox tab, you generally need a plugin. If that didn't come along with the main installer, it appears you can use either of these:

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Amazon MP3 Downloader Plugin 1.0.17
  • Shockwave Flash 11.3 r300
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Version 2.9.10.7526
  • GEPlugin
  • 5.1.10411.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (masking-agent; rv:13.0) Gecko/20100101 Firefox/13.0.1
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Collusion 0.25 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Ghostery 2.8.4 (firefox@ghostery.com)
  • Masking Agent 1.3.0 (maskingagent@basa.nl)
  • Nuke Anything Enhanced 1.0.2 ({1ced4832-f06e-413f-aa14-9eb63ad40ace})
  • Save as PDF 1.5 (save-as-pdf-ff@pdfcrowd.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • NoScript 2.6.5.7 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 540M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x0df4
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1024
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 5-23-2011
  • driverDate2: 3-6-2011
  • driverVersion: 8.15.10.2405
  • driverVersion2: 8.17.12.6754
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.update: False
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • general.useragent.override: Mozilla/5.0 (masking-agent; rv:13.0) Gecko/20100101 Firefox/13.0.1
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1361255261
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

Chosen Solution

In order to render content in a Firefox tab, you generally need a plugin. If that didn't come along with the main installer, it appears you can use either of these:

dadadata 0 solutions 1 answers

Helpful Reply

1. used about:config to change the pdfjs.disable to true 2. went to the Options/Applications and set the Adobe Acrobat Document app to "Adobe Acrobat (in Firefox)." Had the blue plugin lego.

Got my Acrobat XI in a tab, back. Some auto upgrade must have brokenmy settings but I can tell you the built-in reader is awful, at least on this ancient PC.

Helpful Reply

Thank you for the answer about updating the Foxit plugin. Firefox tags the Foxit plugin as potentially unstable, so it turns out I had another program killing the plugin's startup process so it was always disabled in firefox. I reenabled its startup process and updated the plugin. To get firefox to use it as the main pdf reader I went to options>applications and changed the option for pdf to the foxit plugin and everything works dandy now! Thanks again!