Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox sometimes doesn't load google.com

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by cor-el

more options

We have a problem on 2 out of 41 computers running firefox. At a random intervals google.com stops working. Clearing cache sometimes helps, but not always. The problem dissapears after some time. The error message is "Secure connection failed" - Apparently the website did not send any creditentials. (I don't have screenshot at this time, it returned to normal again just before I got to the user having this issue)

The problem exists only on two computers, and only in Firefox. Edge and Chrome are working without any problems on both machines.

All Replies (2)

more options

Try to go to about:config, set "network.http.http3.enabled" = false. Restart Firefox and report back if it's still happening.

Modified by TyDraniu

Helpful?

more options

You can also check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.