Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Private browsing in iOS

  • 3 replies
  • 5 have this problem
  • 751 views
  • Last reply by gneppert

more options

How do I set Private Browsing as the default so I don't have to activate it every time I open the app? It used to just stay on private browsing all the time when opening the app until the update. Now that feature does not work anymore. Very frustrating to have to go in and look at your tabs and adjust every single time.

How do I set Private Browsing as the default so I don't have to activate it every time I open the app? It used to just stay on private browsing all the time when opening the app until the update. Now that feature does not work anymore. Very frustrating to have to go in and look at your tabs and adjust every single time.

Chosen solution

It just got reset during the update. To set it back, tap the hamburger buttons (three lines, lower right), tap Settings> then scroll down to Close Private Tabs (When Leaving Private Browsing)> toggle that to the OFF position (gray). In that position, every time you open the browser it will open to a Private tab. In the ON position (green), when exiting the browser it will close any open private tabs, so that when the browser is opened again it will open to the default, basic, not private tab. Hope this helps.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

It just got reset during the update. To set it back, tap the hamburger buttons (three lines, lower right), tap Settings> then scroll down to Close Private Tabs (When Leaving Private Browsing)> toggle that to the OFF position (gray). In that position, every time you open the browser it will open to a Private tab. In the ON position (green), when exiting the browser it will close any open private tabs, so that when the browser is opened again it will open to the default, basic, not private tab. Hope this helps.

more options

This is a good workaround.

However it has a limitation.

@Mozilla Please add an option to make tab mode selectable.

I like the option of closing tabs on exit.

So I need both.

Settings >

Open new tabs as: [default, private, last used]

Close tabs after exit: [on, off]

Thank you.

more options

Hi,

I also have the same annoying problem, and it manifested itself quite recently.

Just until a short while ago, it worked perfectly well:

New windows were private per default, and all private windows were closed when exiting Firefox.

The workaround that @lpsears63 provided is better than nothing, but by far not as good as the solution that was already there!!