Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Redirecting http: to https:

  • 4 replies
  • 1 has this problem
  • 36 views
  • Last reply by wsquared1

more options

Firefox is redirecting a particular http:// site to https:// Can't figure out how to stop the redirection. It is an unsecured site I am trying to access. Tried various fixes from the community to no avail.

The redirection started earlier this month.

Firefox is redirecting a particular http:// site to https:// Can't figure out how to stop the redirection. It is an unsecured site I am trying to access. Tried various fixes from the community to no avail. The redirection started earlier this month.

Chosen solution

Did a Refresh. That worked! It did require reinstalling addons and resetting some personalizations though.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Did a Refresh. That worked! It did require reinstalling addons and resetting some personalizations though.

more options

I think one of our suggestions would have been to investigate whether the newer "HTTPS Only Mode" feature could be behind the problem. In case the issue recurs, here's the relevant article: HTTPS-Only Mode in Firefox

more options

This could also be a problem with the SiteSecurityServiceState.txt file in the Firefox profile folder.

more options

Tried unchecking the "HTTPS Only Mode" which seemed logical. Didn't work though. The SiteSecurityServicesState and other items in the Firefox Profiles required more investigation time than I was willing to spend. Doing a Refresh did solve the problem. Thanks everyone.