Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox wont open file browser via websites

  • 7 replies
  • 1 has this problem
  • 18 views
  • Last reply by jonzn4SUSE

more options

I'm running Linux Ubuntu 20.4

Whenever I try to use a website that has a browse button (e.g. youtube uploader, google drive, etc) I click it but nothing happens, no file browser comes up.

As per previous discussions on this issue, I have tried Safe mode, refresh (in fact total new operating system and re-install of firefox) and disabling hardware acceleration, even turning off popup blocker and none of these have made any difference.

Chosen solution

In the end I downgraded to Ubuntu 16.04 - problem solved.

Read this answer in context 👍 1

All Replies (7)

more options

Can you provide steps to replicate and screenshot(s) of the issue?

Helpful?

more options

jonzn4SUSE said

Can you provide steps to replicate and screenshot(s) of the issue?

Steps:

1. visit any website with a "browse" button for upload, e.g. https://convert-video-online.com/

2. Click the "open file" button

Screenshot attached (although it's hard to show a screenshot of nothing happening!)

Helpful?

more options

PS.. I have chrome on the same OS and that works fine so I know it's a specific problem with firefox

Helpful?

more options

here is my version

Helpful?

more options

I have an update...

I just noticed that somehow I ended up with two instances of firefox on my system.

On one of those, the browse buttons work fine, on the other they don't.

One of the previous solutions mentioned here for this problem was to disable hardware acceleration... however, simply unchecking the button in settings doesn't seem to work...

I edited the firefox.desktop file in usr/share/appications, inserting some code to force disabling of hardware acceleration. I suspect this may have worked but am going to re-install everything and repeat steps to make sure I have it figured out.

Will report back soon.

Helpful?

more options

Chosen Solution

In the end I downgraded to Ubuntu 16.04 - problem solved.

Helpful?

more options

The button works for me. Did you every try a separate copy of Firefox in Ubuntu 20?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.