Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When you open a link, image or media in a new tab, switch to it immediately

more options

Hi there,

"When you open a link, image or media in a new tab, switch to it immediately" is happening - even though the box is unticked.

It's very irritating, so i hope there is a solution...?

Cheers

Chosen solution

Hi editoratlarge, that checkbox on the Settings page needs to be understood very literally:

"When you open a link, image or media in a new tab, switch to it immediately"

If the link opens in a new tab automatically -- because it was coded to launch a new window and Firefox diverted it to a new tab instead -- then Firefox will switch immediately.

There is a setting for that, but it's a little harder to access:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

Firefox should now list several related preferences and you can choose your preferred behavior. In alphabetical order:

  • browser.search.context.loadInBackground is set to false by default. This is for those searches you run by selecting text in a page, right-clicking, and using the item "Search Google for [text]" (or if your default search engine is not Google, your default search engine will be mentioned there instead). Not your issue, but something to consider experimenting with for the future.
  • browser.tabs.loadBookmarksInBackground is set to false by default. Not your issue, but something to consider experimenting with for the future.
  • browser.tabs.loadDivertedInBackground is set to false by default. **THIS ONE** This covers the case where the link is coded to open in a new window and Firefox diverts it to a new tab instead -- Firefox switches to those immediately. Try double-clicking the preference to switch the value from false to true.
  • browser.tabs.loadInBackground is set to true by default and is the one that has the checkbox on the Options page. This covers the case where you specifically direct a link to a new tab, for example, from the right-click context menu, or by Ctrl+clicking or middle-clicking a link. I suggest double-clicking it to false, and then double-clicking it back to true, just to make sure you and Firefox are on the same page.
  • Ignore the services.sync.prefs.sync.browser.tabs.loadInBackground preference, this just tells Firefox whether to include the next preference when it Syncs preference.
Read this answer in context 👍 2

All Replies (3)

more options

Are you opening these items via a link on a webpage or directly via the location bar or via a bookmark or otherwise ?

Helpful?

more options

Chosen Solution

Hi editoratlarge, that checkbox on the Settings page needs to be understood very literally:

"When you open a link, image or media in a new tab, switch to it immediately"

If the link opens in a new tab automatically -- because it was coded to launch a new window and Firefox diverted it to a new tab instead -- then Firefox will switch immediately.

There is a setting for that, but it's a little harder to access:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

Firefox should now list several related preferences and you can choose your preferred behavior. In alphabetical order:

  • browser.search.context.loadInBackground is set to false by default. This is for those searches you run by selecting text in a page, right-clicking, and using the item "Search Google for [text]" (or if your default search engine is not Google, your default search engine will be mentioned there instead). Not your issue, but something to consider experimenting with for the future.
  • browser.tabs.loadBookmarksInBackground is set to false by default. Not your issue, but something to consider experimenting with for the future.
  • browser.tabs.loadDivertedInBackground is set to false by default. **THIS ONE** This covers the case where the link is coded to open in a new window and Firefox diverts it to a new tab instead -- Firefox switches to those immediately. Try double-clicking the preference to switch the value from false to true.
  • browser.tabs.loadInBackground is set to true by default and is the one that has the checkbox on the Options page. This covers the case where you specifically direct a link to a new tab, for example, from the right-click context menu, or by Ctrl+clicking or middle-clicking a link. I suggest double-clicking it to false, and then double-clicking it back to true, just to make sure you and Firefox are on the same page.
  • Ignore the services.sync.prefs.sync.browser.tabs.loadInBackground preference, this just tells Firefox whether to include the next preference when it Syncs preference.

Helpful?

more options

Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.