Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Web browser not loading correctly

  • 6 replies
  • 1 has this problem
  • 15 views
  • Last reply by FredMcD

more options

I’m using the latest version of Firefox and have gone through all the troubleshooting advice but websites when viewed in Firefox are not loading or viewing correctly and are slow to load. Please see images attached. This is an example page showing how a page looks in another browser (FF01) and how it looks in Firefox (FF02). This website appears correct in all other browsers. Is anyone having the same problem? Does anyone know how to solve this?

Chosen solution

southerndowner said

Please see images attached.

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Read this answer in context 👍 0

All Replies (6)

more options

Hey there!

Please see the following websites for guidance:

https://support.mozilla.org/en-US/kb/fix-problems-images-not-show (if images can't show up)

https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently (if website looks different)

https://support.mozilla.org/en-US/kb/websites-dont-load-troubleshoot-and-fix-errors (websites can't load)

Hope I helped!

Kind regards,

Bithiah

Helpful?

more options

Hello Bithiah,

Thank you very much for your time and help but I’ve been through all of these suggestions and others on the trouble-shooting pages without any luck.

Kind regards, Geraint.

Helpful?

more options

Chosen Solution

southerndowner said

Please see images attached.

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Helpful?

more options

cor-el said

This could be a problem with High Contrast Mode on Mac. See "New" in the release notes. Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Helpful?

more options

Thank you FredMcD,

But the problem has now been solved.

Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

   Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above" 

Try "Never" if the default "Only with High Contrast themes" isn't working.

Kind regards, Geraint.

Helpful?

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.