Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

web site blocking

  • 10 replies
  • 1 has this problem
  • 34 views
  • Last reply by cor-el

more options

A Medical site blocks me if I use normal browsing, But work ok if I use Private Browsing. I have cleared history and cookies for this site.

Chosen solution

You can check the Web Console for relevant-looking messages to see if there is more detail available.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Read this answer in context 👍 0

All Replies (10)

more options

The site is?

Helpful?

more options

The site is Caremark drug ordering site

Helpful?

more options

after I login, the site says there is a problem, try later

Helpful?

more options

Can you post a screenshot of the issue?

Helpful?

more options

here is image

Helpful?

more options

It is pretty common for websites to deny log in . It might happen because of too many login ids or attempts to log in from the same computer . Think of it like instagram . You log into normal browsing and if you want to log into an another account at the same time you cant really do that in normal browsing simultaneously sooo if you open a private window it allows you to open another instagram account . This is a security feature of the websites to protect them from getting DOS (denial of service) . In my opinion this is not really a problem related to firefox but you can try contacting caremark and check with their customer care or mail their official id about this issue .

Helpful?

more options

raybob60 said

. . . . But work ok if I use Private Browsing.

Some add-ons are not active when using Private Windows.

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages blocked content.

Helpful?

more options

It would help if we could see screenshots of these sections.

Helpful?

more options

Chosen Solution

You can check the Web Console for relevant-looking messages to see if there is more detail available.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.