Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird - unsupported browser - failed Gmail setup

  • 20 replies
  • 2 have this problem
  • 98 views
  • Last reply by bogprs

more options

Dear all,

I have tried setting up Gmail within Thunderbird 78.x.y. After entering credentials, and going again through login to the Gmail popup window I reach a state which is shown in the attached image.

Google security options: 2 factor off, less secure apps on, Captcha refreshed but nothing helps.

Many thanks for the help.

Best, Bogdan

Attached screenshots

All Replies (20)

more options

This has come up in another discussion, but is not yet resolved, or understood:

https://bugzilla.mozilla.org/show_bug.cgi?id=1677845

Do you accept cookies in TB Options/Privacy & Security? It's necessary to complete OAuth2 authentication.

Helpful?

more options

Hello,

Thank you for pointing to the discussion. Yes, I accept all cookies, until expiration, no exceptions.

Best, Bogdan

Helpful?

more options

Hello,

To my disappointment the issue is still unresolved, even in the newest 91.1.2 version. Are there any options to change the behavior or to use non-internal browser?

Many thanks for the help.

Best, Bogdan

Helpful?

more options

I just went to Google, created an account and then after allowing IMAP and POP which Google do not enable by default I tried to add this 2 minute old account to Thunderbird. The following is what I got from google in return.

So this is not an issue for me, I simply can not reproduce the issue. I set up the account without any issue at al after I clicked on the "allow" button. So what is left is something that is different you to me.

You are using Windows 10, I am using windows 10.

You are I guess using an anti virus. I am using only windows defender. Could that be the difference?

Helpful?

more options

Hi Matt.

Thank you for the prompt answer. In fact, your feedback gave me a new insight - it seems that for my particular Google account I do not get this prompt asking for Google permissions. I've tried with another account and it seems to be working.

I will explore the newly discovered path and report here in case someone else encounters the same issue.

Thanks again.

Best, Bogdan

Helpful?

more options

check the authentication method is set to oauth. This is the setting that will be automatically retrieved for new gmail accounts. (IF you are notified the settings were not found in the database, you have other issues. Usually with the firewall)

Check to ensure cookies are enabled. This is the default in Thunderbird, but there are those that turn them off, and of more consequence there is software that does so to "protect your privacy". More concerning because the person has no idea it has happened usually.

Please keep updating this topic with your progress, even if no one replies at the time. I would like to get to the bottom of one of these browser issues once and for all to figure out why anyone sees them. My work cycle often sees me disappear for a week at a time. But that does not say I am not interested.

Helpful?

more options

Hi Matt,

Here is the latest update. It appears that all configuration inside Thunderbird are correctly set (OAuth2, Cookies) (cf. images attached) and ISP configuration for Google properly found. Nevertheless, I experimented a little bit with Google Account and Gmail Settings - basically I deactivated and then re-activated some of the options (IMAP, POP, Third-party App Sign-In prompts, etc.) and the result is even more broken than before - Thunderbird posts "Unable to log in at server. Probably wrong configuration, username, or password.".

I am attaching some Security options of the Google Account that are not activated by default in freshly created accounts but are currently activated in my settings.

I will continue posting updated because now this issue has become personal. :)

Best, Bogdan

Helpful?

more options

Update: I deactivated 2-factor authentication - no changes - Thunderbird still posts "Unable to log in at server. Probably wrong configuration, username, or password.".

I managed to manually add the account despite the error by going "Manual Configuration" and then "Advanced Configuration" - it creates the Google mail account with all pre-defined settings. Nevertheless, when manually clicking on "Get Mail" I get the popup as show on the image.

Modified by bogprs

Helpful?

more options

Update:

I even allowed "Less Secured Apps" in Google Settings. And also tried using https://accounts.google.com/DisplayUnlockCaptcha But to no avail.

Next up on the program: reverting to 2-factor authentication and App Password.

Bogdan

Modified by bogprs

Helpful?

more options

ok, I created the account, allowed IMAP and pop and did nothing else at google..

However your last image might be clue as the wizard is telling you it found it's settings by probing the server. I think you might have a firewall issue.

The wizard should in the first instance reach out to the ISPBD for settings. That is here and read the XML file to get your settings. That this is not occurring indicates an issue at your end. As the result being sought is a HTTPS request just go to the addon manager in Thunderbird (tools menu > addons and themes in in the extensions search for sort and press enter. Are you getting results there starting with manually sort folders? or an error perhaps?

Then try the URL that Thunderbird should return https://addons.thunderbird.net/en-US/thunderbird/search/?q=sort Does that work in your web browser? Given the oauth and the pages I am suggesting you try in Thunderbird are all served through HTTPS requests, that should clarify if Thunderbird's access to the internet is being limited only to mail ports perhaps or mail protocols.

Helpful?

more options

Hi Matt,

I am getting automatic ISP settings for Gmail (cf. the first attached image). Furthermore, Thunderbird is allowed according to Windows Defender Firewall settings (cf. the second image).

I can access the proposed link both through browser and Thunderbird (by searching "sort" in the extensions) (the third image).

Best, Bogdan

Helpful?

more options

bogprs said

Update: I even allowed "Less Secured Apps" in Google Settings. And also tried using https://accounts.google.com/DisplayUnlockCaptcha But to no avail. Next up on the program: reverting to 2-factor authentication and App Password. Bogdan

BTW that link amounts to a load of people that have not managed to find the password manager in Thunderbird (preferences search for pass) and remove the google ones.

Helpful?

more options

Back to the square one after deleting the Google Passwords from Thunderbird.

Gmail ISP settings detected automatically, popup with Google login and authentication, and finally the original message "Your browser is not supported anymore".

I did not see any "Mozilla Thunderbird wants to access your Google Account" as you did in one of the previous images.

Bogdan

Helpful?

more options

bogprs said

Gmail ISP settings detected automatically, popup with Google login and authentication, and finally the original message "Your browser is not supported anymore".

Hi Bogdan, if you visit

Help > Troubleshooting Information

in Thunderbird, the first table should have a line similar to

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Thunderbird/78.12.0

Does yours look similar to that?

Helpful?

more options

Thanks for dropping by jscher2000. You just ran through my about last suggestion (User Agent) but it is a topic that really needs to be resolved. Google have made changes, that is clear

Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1677845 Google reference: https://developers.googleblog.com/2020/08/guidance-for-our-effort-to-block-less-secure-browser-and-apps.html

It was determined that Thunderbird user agent was not an issue, or did not appear to be. But we still get these odd instances where the error comes up. The why needs to be established so either the issue can be documented or fixed if fixing it is an option.

The user agent on the account addition I did was Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:94.0) Gecko/20100101 Thunderbird/94.0a1

Helpful?

more options

Hi Matt, jscher2000

My info looks like: User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Thunderbird/91.1.2

Hope it helps.

Best, Bogdan

Helpful?

more options

Perhaps what is needed it to log the account creation process.

See https://thunderbirdtweaks.blogspot.com/2019/09/i-lost-my-profilemail-on-update-to.html

Perhaps there will be an error in there that will provide a clue.

Helpful?

more options

Hi Matt,

I tried two things:

1. Changing to and launching non-default profile as suggested in the post - when adding Gmail it results as previous tries - "Your browser is not supported" 2. Launching Troubleshoot Mode - same result as in bullet 1.

Looking forward to alternatives. I will continue debugging on my side and reporting here.

Best, Bogdan

Helpful?

more options

Hi Matt, jscher2000,

I have tried even the most radical debug option: clean install of the Thunderbird but to no avail - it results with good old "Your browser is not supported".

I am beginning to suspect that it might be some specific Google settings that are resulting in such a failure. The strange part is that the error does not manifest when using a fresh Gmail account.

Best, Bogdan

Helpful?

more options

Hi Matt, jscher2000,

I think I have finally come to the bottom of this issue. It is described here: https://support.google.com/mail/thread/127545584/i-have-created-a-supervised-account-and-i-m-want-to-add-it-to-my-mail-app-in-mac-but-its-offline?hl=en&msgid=128001398

Basically, according to recommended answer, it boils down to the following sentence:

"Thanks. AFAIK, Accounts managed by Family Link are not allowed to sign in via email clients. I was unable to get my test child account added to Thunderbird. "

Since I have recently started using Family Link to limit screen time on my phone, it seems that it prevents me from accessing Google Mail on Thunderbird.

We can proceed to closing this ticket.

Best, Bogdan

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.