On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bing opens whenever I start Firefox

  • 2 replies
  • 1 has this problem
  • 18 views
  • Last reply by FredMcD

more options

I have my default setting as Firefox as browser and Google as my search engine. In the last few days, Bing always comes up when I open Firefox, but when I open a second tab, the page is Google as it should be. I think this started when I updated. I have checked the default browser setting in Windows 10, and the default search engine in Firefox, and they are both set properly. This is mostly an annoyance, but I would like to know how to change it back to the way I am used to.

I have my default setting as Firefox as browser and Google as my search engine. In the last few days, Bing always comes up when I open Firefox, but when I open a second tab, the page is Google as it should be. I think this started when I updated. I have checked the default browser setting in Windows 10, and the default search engine in Firefox, and they are both set properly. This is mostly an annoyance, but I would like to know how to change it back to the way I am used to.

All Replies (2)

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.


You can check for recently installed suspicious or unknown extensions.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options