Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with embedded video i frame on firefox only.

  • 13 replies
  • 1 has this problem
  • 50 views
  • Last reply by azalewski

more options

Hello i have a problem with view video on my website. Other browsers like chrome, opera, edge works fine, the problem only exists on Firefox. I've tried many things like turning off extensions and site protections, turning off "Use hardware acceleration when available" option, i even allowed autoplay videos and sounds on every site, and problem still isn't solved. You guys have any ideas what's wrong, in older versions of firefox everything worked fine. Here's link: https://www.uczelnie.pl/miasto/warszawa/uczelnia/277/akademia-leona-kozminskiego-alk

All Replies (13)

more options

This page has a lot of issues. Your video is hidden within a div declared with class="test" and style="display: none". It would never work.

Helpful?

more options

TyDraniu powiedział

This page has a lot of issues. Your video is hidden within a div declared with class="test" and style="display: none". It would never work.

Yes but there's a condition (if video error ---> change to display: none) but as i said on chrome, opera, edge it works perfectly, so i think something is wrong with firefox

Helpful?

more options

I can see top part of this video after disabling Tracking protection and allowing Sound & video permission.

Helpful?

more options

Hmmm, i know why he's so small there's anonther script that reads size from database it's depending on video resoultion ratio. But in my browser there's no option button near link, so i manually tried to allow/block video+sound ---> no results it's like browser doesn't know there's video to run.

Helpful?

more options

Try to click the shield icon in the URL bar and turn off Enhanced tracking protection for this site.

Helpful?

more options

No difference, tried it many times and no results :/

Helpful?

more options

Works on mobile phone after allow autoplay videos, but still doesn't work on PC, however i'd like to change it other way. I mean i want random firefox user to watch it :/

Helpful?

more options

That's my version of firefox

Helpful?

more options

OK, perhaps someone else could suggest something. Please remove the "Chosen solution" flair from above post. Your issue is not resolved yet.

Helpful?

more options

I see the video in Nightly (92) and in Beta/DE (91) with the default "Block audio" settings, but not in 89/90.

Helpful?

more options

Yea i think something is wrong with this version, because as i remember, before update video player was OK. I think i have to just wait till 91/92 will be released.

Helpful?

more options

Today at morning i had update on firefox developers to 91.0b2 and normal firefox to 90.0. Developers works, but normal still not working :/

Helpful?

more options

There's still a problem with it, any ideas?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.