Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Entry field is locked

  • 19 replies
  • 1 has this problem
  • Last reply by rjpoulton44

more options

I cannot enter anything into the search field of the Firefox home page. If I go to, it works fine. I have the same problem signing onto my bank's web site. I cannot enter anything into the field to take my debit card number. I uninstalled Firefox and reinstalled it to no avail. If I use the TAB button to go to the next field, it always skips the field I am having trouble with.

All Replies (19)

more options

The first issue u can resolve by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

more options

I changed the about:config to false, and now the Firefox first page works, but my bank login page still has the problem. I need to know whether I should switchback about:config back to "true". I want to share another quirk. When I run Firefox in Troubleshooting mode, my problem goes away. Should I simply always run Firefox in Troubleshooting mode? Are there any issues? Another solution is to switch browsers. But I would like to get to the bottom of this problem. Any more suggestions?

more options

If it works in Troubleshooting mode, it must be done by an addon. Try to turn off your addons.

more options

When I went to menu and selected Add-ons and Themes, then selected Extensions, I had no extensions listed - so none to disable. I liked your idea and feel we are headed in the right direction, but I am still stumped.

more options

Pls provide a website URL with this issue.

more options I cannot enter anything in the field requesting "Card Number" unless I run Firefox in Troubleshooting mode. Any suggestions would be appreciated.

more options

I just found another web site with the problem - but this time with the password field.

more options

rjpoulton44 said I cannot enter anything in the field requesting "Card Number" unless I run Firefox in Troubleshooting mode. Any suggestions would be appreciated.

Could you re-check the Add-ons page, Extensions panel, while in Safe/Troubleshoot Mode? In that mode, extensions cannot interfere with display of the list.

more options

I believe you asked me to go into TroubleShooting mode then check for Add-ons. When I select Extensions under Add-ons and Themes, I get the message: All add-ons have been disabled by safe mode under Manager Your Extensions. Multiple Add-ons are listed under Recommended Extensions, but I assume they are not installed. Am I doing what you expect? This is virtually the same that I got when not in TroubleShooting mode.

more options

I restarted Firefox and did NOT go into TroubleShooting mode. I clicked on the setup icon beside Manager Your Extensions and got: 1 Extension: 4 Service Workers - stopped - stopped - - 0 Shared Workers 4 Other Workers: - resource://gre/modules/osfile/osfile_async_worker.js - resource://modules/sessionstore/SessionWorker.js - resource://gre/modules/PageThumbsWorker.js - resource://activity-stream/lib/PersonalityProvider/PersonalityProviderWorker.js

more options

How do these fields show in the Inspector ? Do they have special attributes ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

On the BMO web site with my problem, I right clicked on the problem field and selected Inspect(O):

<td class="dijitReset dijitStretch dijitButtonContents" role="presentation">
B - 5510********3895
<input class="dijitReset dijitInputField dijitValidationIcon dijitValidationInner" value="Χ " type="text" tabindex="-1" readonly="readonly" role="presentation">
<input type="hidden" name="siBankCardDD" data-dojo-attach-point="valueNode" value="b9b6fc9f94420a1bf0527bbd77b44e90" aria-hidden="true"></td>

Is this what you requested? I do not know what to look for.

more options

In response to the second suggestion . . . 1) I then turned off hardware acceleration. I still have the problem 2) Under Themes, I had 1 enabled and 3 disabled. Enabled: System theme Disabled: Dark Disabled: Firefox Alpenglow Disabled: Light These were followed with 3 Recommended Themes I enabled the Firefox Alpenglow causing the System theme to be disabled. I still have the problem 3) Under extensions no extensions are listed under Manage Your Extensions

more options

rjpoulton44 said

On the BMO web site with my problem, I right clicked on the problem field and selected Inspect(O): <input readonly="readonly" role="presentation"> <input type="hidden" name="siBankCardDD" value=""> Is this what you requested? I do not know what to look for.

Yup. Your fields are blocked somehow, but we can't reproduce it. Did you select Remember my Card previously?

Try to click the lock icon in the URL bar and select Clear cookies and site data…, maybe it'll help.

Modified by TyDraniu

more options

Thank you for another suggestion, but it did not let me access the field. I tried it on my BMO and HomeDepot logins. I expect I have a computer issue, but it really puzzles me how it materializes in Firefox (only).

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

I did the "Forget About This Site" and my BMO Card Number field still cannot accept data. Thanks for trying.

more options

I just had a different experience with my same problem. Since I had cleared so much off, when I tried to log onto a bank account I rarely log onto, it took my ID and password, but since it did not recognize my computer as a trusted computer, it send a code to my email that I had to enter so it would remember logging on from this computer was OK. Now when I try to logon, I cannot enter anything into the password field. So does that mean it has something to do with information saved about web sites I access?