Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

v.89 browser tabs and menus spacing too large

  • 4 replies
  • 1 has this problem
  • 42 views
  • Last reply by kbfoster108

more options

For starters, stop making assumptions about how people prefer their spacing on menus and tabs. Both are, with the latest update, too effing large, resulting in less visible screen space and an excessive amount of scrolling to access bookmarks. Do you think everybody is blind?! I desperately want to go back to the spacing in the previous version of Firefox. Is there a way to do that without downgrading to v.88? Also, the change to the color scheme makes it a lot harder to quickly see which tab is active as there isn't enough contrast.

I stopped using Chrome except in emergencies because they kept taking away my options to make the browser comfortable to me. Mozilla is now doing the same thing and it really pisses me off. You say you are making things better and/or easier, but that is only your opinion. I know you can't please everybody but why take away the ability to make tabs and menus more compact so less space is wasted and scrolling doesn't take longer?

Chosen solution

You can possibly use code in userChrome.css to override changes coming in Firefox 89+ with the new Proton design.

Read this answer in context 👍 1

All Replies (4)

more options

Hi

Thank you for your feedback.

Starting in Firefox 89, Compact Mode is no longer supported. If you've been using Compact Mode on a previous version, you should be able to retain the feature. However, for the best experience, we encourage you to use the default Density setting.

If you are an advanced user, it's still possible to activate it in the Configuration Editor (about:config page).

  1. Type about:config in the address bar and press Return. A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
  2. Find the browser.compactmode.show preference.
  3. Switch the toggle to true and then close the tab.
  4. Click on the menu button fx89menuButton to open the menu panel.
  5. Click More Tools menu.
  6. Choose Customize Toolbar.
  7. At the bottom of the panel, click the Density button.
  8. Choose Compact (not supported) from the menu options.
  9. Click Done.

More about that: Compact mode workaround in Firefox

Helpful?

more options

This fix only worked on the tabs and not the menus, and it's the menus that really need to be more compact. As it stands now, I will have to do a lot of extra scrolling every time I want to access a link in my bookmarks. Why is Mozilla forcing their opinion of what is best on users?

Helpful?

more options

Chosen Solution

You can possibly use code in userChrome.css to override changes coming in Firefox 89+ with the new Proton design.

Helpful?

more options

Thank you cor-el. I've got my screen space back and menus (especially bookmarks) back to not needing to scroll.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.