Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot appply to jobs on indeed.com

  • 5 replies
  • 1 has this problem
  • 17 views
  • Last reply by FredMcD

more options

When viewing a job on Indeed, whether on a pane or a separate tab, the application menu fails to load when I click 'Apply Now'. The connection times out after a while. It even takes an awful time to go back (reload) to the page!

When I reported this Indeed Support, they recommended using Google Chrome as their site "tends to work best on it". I can now confirm that the issue does not arise with Chrome.

I have tried pretty much everything on this page: Firefox can't load websites but other browsers can

I even reinstalled Firefox but it is so smart, it realized the fact and prompted me to refresh and now we are back where we left off.

Attached screenshots

Chosen solution

As long as the problem is gone. Please flag your last post as Solved Problem as this can help others with similar problems.

Read this answer in context 👍 0

All Replies (5)

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

The problem persists even in Troubleshooting mode. Turned off enhanced tracking protection, disabled hardware acceleration, deleted Firefox preference files; nothing doing!

I also found this thread from a year ago that reports the same issue.

Helpful?

more options

Try this link: https://in.indeed.com/

Helpful?

more options

Thank you. Appreciate the prompt response!

I've been visiting this very domain, if you will see my original post! But don't bother, the problem has fixed itself very miraculously, without tweaks or sacrifice. I blame the website- whenever they make any changes, this occurs; they even suffered a serious security breach sometime back.

Thank you again for reaching out!

Helpful?

more options

Chosen Solution

As long as the problem is gone. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.