Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't sign in to Firefox Account

  • 5 replies
  • 1 has this problem
  • 408 views
  • Last reply by FredMcD

more options

I switched from Chrome to Firefox recently, but am unable to sign in to my Firefox Account (whilst using Firefox). I'm on 88.0 (64-bit) on the latest public release of macOS.

Whether I try to sign into Firefox Sync using Firfox's menu or Preferences screen, or try to load accounts.firefox.com — just nothing happens: in the browser, the Sign In button doesn't do anything, and trying to load the URL I just get a blank screen. If I go to https://support.mozilla.org/en-US/fxa/authenticate, and click the 'Continue with Firefox Accounts' button, again - nothing happens.

I've rebooted my machine, disabled my VPN, and disabled any add-ons which might conflict. I'm posting this question having signed in via Safari, so I know my account works and my network connection is okay.

I couldn't find any Help articles. Does anyone have some suggestions I could try please

I switched from Chrome to Firefox recently, but am unable to sign in to my Firefox Account (whilst using Firefox). I'm on 88.0 (64-bit) on the latest public release of macOS. Whether I try to sign into Firefox Sync using Firfox's menu or Preferences screen, or try to load accounts.firefox.com — just nothing happens: in the browser, the Sign In button doesn't do anything, and trying to load the URL I just get a blank screen. If I go to https://support.mozilla.org/en-US/fxa/authenticate, and click the 'Continue with Firefox Accounts' button, again - nothing happens. I've rebooted my machine, disabled my VPN, and disabled any add-ons which might conflict. I'm posting this question having signed in via Safari, so I know my account works and my network connection is okay. I couldn't find any Help articles. Does anyone have some suggestions I could try please

Chosen solution

I found the issue. I run a network monitor in the background and for an unknown reason it was blocking the firefox.com domain within Firefox browser — which is why the URL wouldn't load, but nor would I get an error messages. I think it's solved for now. Thank you for your help though! it was while I was recording a screencast to show the issue I looked at the network monitor and found the problem. Cheers

Read this answer in context 👍 0

All Replies (5)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Hi FredMcD - thanks for your help

I tried your suggestions, with no luck.

- loaded Firefox in safe mode, the problem remains - staying in safe mode, I cleared the whole cache, no change - when I enter 'www.firefox.com' or 'accounts.firefox.com' no page loads, not even the URL - likewise the sign-in to sync button in Preferences does nothing - if I enter 'www.getfirefox.com' I am forwarded to the mozilla site however - my VPN is off, and I've switched to a different wifi network too, still no luck

Do you have any further thoughts?

Modified by accs

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

more options

Chosen Solution

I found the issue. I run a network monitor in the background and for an unknown reason it was blocking the firefox.com domain within Firefox browser — which is why the URL wouldn't load, but nor would I get an error messages. I think it's solved for now. Thank you for your help though! it was while I was recording a screencast to show the issue I looked at the network monitor and found the problem. Cheers

more options

That was very good work. Well Done.