Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

am making firefox my default browser but when it comes to default apps cannot do it

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

what and how can change default apps for for firefox default browser ...... can not do it am lost

All Replies (2)

more options

Hey there!

Once the "default apps" dialog opens, you need to scroll to the bottom and select the "Web browser" option. It'll probably be "Microsoft Edge" or "Google Chrome."

Then, you'll want to click it and select "Firefox."

If Firefox isn't showing up, try reinstalling it. This is a Windows bug, unfortunately, and that's the easiest way I've found to fix it.

Let me know if you need any more help!

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.