Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to revert from Beta 88.0b1 (64-bit) back to normal release channel?

  • 38 replies
  • 2 have this problem
  • 119 views
  • Last reply by ska.adley

more options

I need to get out of the Beta releases ...88.0b1 (64-bit) ... and back to regular release.

How do I do that and retain all the emails, address books and Enigmail settings?

I have tried starting the beta with "Thunderbird --allow-downgrade" but the version remains the same Beta 88.

All Replies (20)

more options

you have to install the release version then set the profile to use as the same one and then use the command line switch.

more options

Thank You.

This worked. However, the Address Book(s) were not imported, or transferred over. The passwords were not transferred over.

I went back into the beta version and exported each address-book as .csv. Then imported them into the default Release Version. But thought the new address book showed the sub-address-books, they were not populated. TB gives a warning that remote address books must be searched first. A search proved useless.

Amy further help on this Matt?

Many thanks.

more options

There were some changes made in address books sometime after beta 82. The database schema got changed. I think the current version used in beta 88 is *.v3.sqlite. So would need to restore the *.v2.sqlite files in your profile. It's enough to make you mad especially as the help info on this takes some digging to locate. https://bugzilla.mozilla.org/show_bug.cgi?id=1684981

Matt: are you able to offer some additional info on this ?

more options

I went up and down the BugZilla page yet failed tofind directions to revert to .v2.sqlite

I still have the Beta version installed in a different directory. So technically it is possible to run the TB.exe and be back in the beta release ... do some magic, yet known to me, about Address Book save in v2-sqlite then runh from the command prompt tb exe --allow etc etc

more options

Found some additional info that may help for version 88 beta 2 released April 2, 2021.

TB changed the sending pipeline completely in TB 88. Resulting problems are investigated in bug 1702360. Check the release notes to find out how to revert to the "old" sending pipeline: https://www-stage.thunderbird.net/en-US/thunderbird/88.0beta/releasenotes/ The old behavior can be restored by setting the preferences "mailnews.send.jsmodule" and "mailnews.smtp.jsmodule" to false.

Menu app icon > Options > General Scroll to bottom (or type: Config Editor into the 'Find in Options' top right search) click on 'Config Editor' Then you can search for: jsmodule It should show you the two preferences: "mailnews.send.jsmodule" and "mailnews.smtp.jsmodule" Double click on each line to toggle the preference from True to False Close the config window Restart Thunderbird.


However, as you currently have the 78* version running, it would be helpful to let me know what you see in the 'profile name' folder for all the address books that have a sqlite format. In 78*, you would typically see: abook.sqlite (Personal Address Book) history.sqlite (Collected Addresses) abook-1.sqlite (numbered for address book you created)

Do you now see something else as well eg: abook.sqlite.bak and perhaps something like abook.v2.sqlite or abook.v3.sqlite ? Post an image as it may help if I need to advise others in the future.

more options

I have, it looks like, many variants of abook. In some cases it might be from many attempts to import csv AB's the last few days.

Also there seems to be no smtp.jsmodule

more options

re :Also there seems to be no smtp.jsmodule That would only be available in the beta 88 to switch off the new send model. Note: the developers area ware of this sending bug and they are working on it, so likely to get sorted for next beta update.

re: version 78* In 'profile name' folder, open 'prefs.js' file using Notepad. scroll down to the section that starts: user_pref("ldap_2.servers. Please can you post images that show all the information for any line starting with user_pref("ldap_2.servers.

This will tell us eg: the dirType number and also filename that Thunderbird is currently selecting.

I really appreciate your assistance with this as it is helping me to fully understand what is going on with all these various updates as it seems likely there are going to be people needing help.

Modified by Toad-Hall

more options

check PM for link

more options

Got the link and all looks good in 'prefs.js'.

Exit Thunderbird.

Please do the following in 'profile name' folder: For all files that have the following format (not the ones with v2 in the name): eg: abook.sqlite, abook-1.sqlite, etc, impab.sqlite, impab-1.sqlite, history.sqlite Rename by adding .bak, so they become eg: abook.sqlite.bak

Then for all the files that have the v2 eg: abook.v2.sqlite, abook-1.v2.sqlite etc rename by removing the .v2, so they now renamed as abook.sqlite, abook-1.sqlite etc

In other words, you need to use all the files that currently have *.v2.sqlite type of name and rename them. So in the end you have files eg: abook-1.mab.bak (same as before) abook-1.sqlite.bak (previously abook-1.sqlite) abook-1.sqlite (previously abook-1.v2.sqlite)

then Start Thunderbird and report back on results.

Modified by Toad-Hall

more options

not sure if you're meaning a hard abook-xx.sqlite style or anything with sqlite in it except squlite and NOT v2

I see things like this too

cookies.sqlite-wal places.sqlite local.sqlite-wal abook-10.sqlite abook-10.v2.sqlite openpgp.sqlite

and so forth

more options

I'm passing on this info after discussion with a person that helps in bugzilla/developer forum who explained to me what was going on and they had success after doing the following. I'm only talking about the address books. The address books only start with distinctive names. abook, impab, history. They start with abook and the default address book Thunderbird auto creates called 'Personal Address Book' is abook.sqlite and additional address books you created will have the additional number eg: abook-1.sqlite

Ignore/leave as is - all the files that have same name but have extensions .sqlite-shm and .sqlite-wal Ignore all the ones that have a .mab.bak extension eg: abook.mab.bak, they were created and used in version 68 and older.

All the ones that have the .sqlite extension are those created and used since 78* versions, but they are currently not accessible as used for beta. All the ones with the additional v2 in their name were created as a backup when using beta. So we need to do a bit of swapping of names to get access to those backed up address books.

Files that need renaming - I think I've got them all :) Please rename in the order I've listed. You have to rename old .sqlite to .sqlite.bak before renaming the v2 to original .sqlite.

abook.sqlite - rename as abook.sqlite.bak (adding .bak to name) abook.v2.sqlite - rename as abook.sqlite (removing the .v2 from name)

abook-1.sqlite - rename as abook-1.sqlite.bak (adding .bak to name) abook-1.v2.sqlite - rename as abook-1.sqlite (removing the .v2 from name)

abook-2.v2.sqlite - rename as abook-2.sqlite (removing the .v2 from name)

abook-3.sqlite - rename as abook-3.sqlite.bak abook-3.v2.sqlite - rename as abook-3.sqlite

abook-4.sqlite - rename as abook-4.sqlite.bak abook-4.v2.sqlite - rename as abook-4.sqlite

abook-5.sqlite - rename as abook-5.sqlite.bak abook-5.v2.sqlite - rename as abook-5.sqlite

abook-6.sqlite - rename as abook-6.sqlite.bak abook-6.v2.sqlite - rename as abook-6.sqlite

abook-7.sqlite - rename as abook-7.sqlite.bak abook-7.v2.sqlite - rename as abook-7.sqlite

abook-8.v2.sqlite - rename as abook-8.sqlite

abook-9.sqlite - rename as abook-9.sqlite.bak abook-9.v2.sqlite - rename as abook-9.sqlite

abook-10.sqlite - rename as abook-10.sqlite.bak abook-10.v2.sqlite - rename as abook-10.sqlite

abook-11.sqlite - rename as abook-11.sqlite.bak abook-11.v2.sqlite - rename as abook-11.sqlite

abook-12.sqlite - rename as abook-12.sqlite.bak abook-12.v2.sqlite - rename as abook-12.sqlite

There will also be some address books that start with impab. I'm not sure of all the numbered versions you have, but I'm sure the following will give you the idea. These are the imported address books.

impab.sqlite - rename as impab.sqlite.bak (adding .bak to name) impap.v2.sqlite - rename as impab.sqlite (removing the .v2 from name)

impab-1.sqlite - rename as impab-1.sqlite.bak (adding .bak to name) impap-1.v2.sqlite - rename as impab-1.sqlite (removing the .v2 from name)

impab-5.sqlite - rename as impab-5.sqlite.bak (adding .bak to name) impap-5.v2.sqlite - rename as impab-5.sqlite (removing the .v2 from name)

Finally there will be one called 'history' and this is a default thunderbird address book called 'Collected Addresses'.

history.sqlite - rename as history.sqlite.bak (adding .bak to name) history.v2.sqlite - rename as history.sqlite (removing the .v2 from name)

more options

Some that you listed for change did not exist. In the case of Impab there were discrepancies as well as history had same ... so before Ialter them, I am including a couple jpegs for u to view

more options

Image 2 - (second image in last comment) looks like you have renamed files as all the v2 files no longer exist.

All the files that have same name but have extensions .sqlite-shm and .sqlite-wal which I said to ignore and leave alone, they are not displaying either, so I presume you have sorted the view in some way that excludes them. Please confirm they still exist.

The only one that concerns me is the abook.sqlite.bak because it seems as if there was no abook.v2.sqlite file for you to rename to take it's place. Although it seems abook-3.sqlite may have the data as it does have the same filename in prefs.js. Hopefully a new empty one would get produced, but it would be interesting to see if abook-3 contains that data.


Image 1 - and I'm presuming there was a similar situation with 'history.sqlite' file - in that the history.v2.sqlite did not exist - however, I did notice that history.sqlite also has a duplicate address book using abook-6.sqlite - they have same name 'Collected Addresses' according to the info in prefs.js file.

Again in Image 1, there are no files that have same name but have extensions .sqlite-shm and .sqlite-wal; which I said to ignore and leave alone, they are not displaying either, so I presume you have sorted the view in some way that excludes them. Please confirm they still exist.

It would seem the impab set of files did not have a set of v2 files. However, in the 'prefs.js file I did notice that : impab-1.sqlite also has a duplicate address book of same name using abook-4.sqlite and identical size. impab-5.sqlite also has a duplicate address book of same name using abook-9.sqlite and identical size.

So at this point all is ok.

If required we can revisit the default address books.

Start thunderbird and see what happens.

more options

ok, started TB.

The thing I notice is that when I try to write an email ...type the first part of the name or address onto the "TO:" line, no longer am I shown likely email addresses.

more options

Check settings are selected: Menu app icon > Options > Composition Under 'Addressing' section When addressing messages....... Select 'Local Address Books'


Perform a test to check interference from any addons/extensions: Start Thunderbird in Safe Mode and see if the issue disappears. https://support.mozilla.org/en-US/kb/safe-mode-thunderbird

more options

I'm using 78.9.1 (latest release) You could check you have the same info as me.

Additional check: Menu app icon > Options > General scroll to bottom and click on 'Config Editor' There will be a friendly warning :) In search type: autocomplete

mail.addr_book.autocompletequery.format String has Value: (or(DisplayName,c,@V)(FirstName,c,@V)(LastName,c,@V)(NickName,c,@V)(PrimaryEmail,c,@V)(SecondEmail,c,@V)(and(IsMailList,=,TRUE)(Notes,c,@V)))

mail.addr_book.autocompletequery.format.phonetic String has Value: (or(DisplayName,c,@V)(FirstName,c,@V)(LastName,c,@V)(NickName,c,@V)(PrimaryEmail,c,@V)(SecondEmail,c,@V)(and(IsMailList,=,TRUE)(Notes,c,@V))(PhoneticFirstName,c,@V)(PhoneticLastName,c,@V))

I've posted an image below showing my current settings as a guide. You may not have some of them eg: morecols as this was an older addon. But it should give you an idea of what currently works. As 88 had some changes, it may be worth checking the two string values I've copy pasted above, so you can use them if required to modify.

Modified by Toad-Hall

more options

both auto-complete as-well-as select-local-address-books are the same as yours

and still when I try to begin an address-book listing in the "TO:" area, there is no auto-complete.

I wonder if the many same-name address books, some empty and some populated, can be causing this?

more options

What did you see in the 'Config Editor'? see my previous comment regarding: mail.addr_book.autocompletequery.format mail.addr_book.autocompletequery.format.phonetic

In Address Book: Do you see two Personal Address Books? It would be helpful if you could post an image showing the address book list on the left side and underline those that are empty.

Usually the default 'Personal Address Book' is at the top. If it is empty and you have another 'Personal Address Book', try adding a couple of addresses into the default 'Personal Address Book' and restart Thunderbird.

more options

What happens if you restart Thunderbird in Safe Mode? Help > Restart Thunderbird in SAfe Mode.

more options

Safe-Mode made no difference.

these two were exact, as I said

mail.addr_book.autocompletequery.format mail.addr_book.autocompletequery.format.phonetic

there are two "Personal Address Book" entries ... as well as other dupe AB's ... some with entries and some without.

  1. 1
  2. 2