Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to revert from Beta 88.0b1 (64-bit) back to normal release channel?

  • 38 replies
  • 2 have this problem
  • 119 views
  • Last reply by ska.adley

more options

I need to get out of the Beta releases ...88.0b1 (64-bit) ... and back to regular release.

How do I do that and retain all the emails, address books and Enigmail settings?

I have tried starting the beta with "Thunderbird --allow-downgrade" but the version remains the same Beta 88.

All Replies (18)

more options

Did you forget to post an image of address book list ? I got personal message saying you were posting image.

more options

sorry. I did post the link albeit a bit late

more options

I have not heard anything on this problem for a while. Problem still exists. This is where we stand now:

Address books are not seen by TB when I am composing an email.

more options

You said you would post an image : hi I made a screenshot ...put a hand-drawn "0" zed by empty and a rudimentary checkmark by those that were populated

I got a second PM reply but the link was for the same 'prefs.js' file image previously sent and not the 'Directory Pane' of Address Book. You can post that image into this forum as it will not contain any actual contact data. It is helpful to have info in this forum question as other helpers like Matt will also see what's going on.

more options

I can see image and it really does look like the default address books are none functioning. I'm not sure whether you imported the second 'Personal Address Book' and 'Collected Addresses' or whether this was something Thunderbird did when it backed up v2 files.

Let's try to force a new sqlite file by using the old mab file. You do not have anything to lose.

Exit Thunderbird Access profile name folder locate : 'abook.sqlite' - rename as 'abook-20.sqlite.bak' (using number much larger than you have previously used - easy to remember) 'abook.mab.bak' rename as 'abook.mab'

'history.sqlite' - rename as history-20.sqlite.bak 'history.mab.bak' - rename as 'history.mab'

now open 'prefs.js' file using Notepad locate: user_pref("ldap_2.servers.PersonalAddressBook_1.description", "Personal Address Book"); Alter carefully so it says: user_pref("ldap_2.servers.Personal.description", "Personal")

user_pref("ldap_2.servers.PersonalAddressBook_1.dirType", 101); Alter so it says: user_pref("ldap_2.servers.Personal.dirType", 101);

user_pref("ldap_2.servers.PersonalAddressBook_1.filename", "abook-3.sqlite"); alter so it says: user_pref("ldap_2.servers.Personal.filename", "abook-3.sqlite");

user_pref("ldap_2.servers.PersonalAddressBook_1.uid", "14430- plus a load of other numbers "); Alter to say: user_pref("ldap_2.servers.Personal.uid", "14430- plus a load of other numbers do not edit this bit");


Then do same for the Collected Addresses: user_pref("ldap_2.servers.CollectedAddresses_1.description", "Collected Addresses"); alter to say: user_pref("ldap_2.servers.Collected.description", "Collected");

user_pref("ldap_2.servers.CollectedAddresses_1.dirType", 101); Alter to say: user_pref("ldap_2.servers.Collected.dirType", 101);

user_pref("ldap_2.servers.CollectedAddresses_1.filename", "abook-6.sqlite"); Alter to say: user_pref("ldap_2.servers.Collected.filename", "abook-6.sqlite");

user_pref("ldap_2.servers.CollectedAddresses_1.uid", "58feece- plus a load of other numbers "); Alter to say: user_pref("ldap_2.servers.Collected.uid", "58feece- plus a load of other numbers do not edit this bit");

Double check you have this all correct. Spelling is important. Save the 'prefs.js' file

Start Thunderbird new abook.sqlite and history.sqlite will get created.

REport back on what you now see in Address Book.

more options

Did changes as suggested. And ... Well, the address books seem fine. Those that were duplicated at the Folder level, are not populated. OK, ONE is, the "Dupe" isn't .

However, when I begin to type a name in the "TO:" Line, as before, TB doesn't help me find the email address. See attachment.

And thanks for your patience on this one.

more options

re :Did changes as suggested. And ...Well, the address books seem fine.

The default 'Personal Address Book would be the top one and the 'Collected Addresses' would be at the bottom. They were empty before - are you saying both of them are now fully working ? You can access them and see contacts, add contacts etc? So we can say that at least that part of the problem is now fixed.

Can you send me another image of Address Book directory pane indicating which is currently empty, so we can sort out the remainder?

more options

What addon extensions are currently installed? What addon extensions have you used in the past, but perhaps stopped using after version 68?

more options

As you do not need additional dupes, even if name is now slightly different...

If the default 'Personal Address Book' is now working: move all the contacts that are in 'Personal' into the 'Personal Address Book' then delete the 'Personal' address book.

If the default 'Collected Addresses' address book is now working: move all the contacts that are in the 'Collected' address book into the 'Collected Addresses' address book Then delete the 'Collected' address book.

Report back saying you have done this.

then post image showing the new look of the Address Book directory pane. put a 0 next to those address books that are currently empty.

Modified by Toad-Hall

more options

I've just realised that you may now have 'personal' and 'Personal' both as address books. If 'personal' is really a dupe of what you have in 'Personal' and now you have moved all contacts to 'Personal Address Book', then both 'personal' and 'Personal' should be deleted.

Note: In 'Personal Address Book' which should now have all those contacts, please check that the data stored is in the correct location eg: Name is the name, - check the Edit Contact has First and Last name correctly inputted. Run through each contact making sure the data is correctly inserted and Email really is the email address. Autocomplete can fail if data is in the wrong field.

more options

As the second person to have this problem, I'll report what I have done so far to see if it sheds any light. I have not solved this either.

When I downgraded from beta to 78, I also found an empty address book. I don't remember where I got this idea, but I copied an abook.mab from an old profile that was not on a beta release into the 78 profile and restarted Tbird. The abook.mab was backed up and an sqlite file was created. I now had an Address Book with my data in it.

I can right-click an entry in the Address Book and send a message from there, but the autocomplete doesn't work for me either if I start from the Write dialog. Nor does it collect addresses from new recipients.

Here are the address files I have: abook.mab.bak abook.sqlite abook.sqlite-wal history.sqlite history.sqlite-wal I don't have any impab files.

I've added a screenshot of the address directory.

Here's what my pref.js has: user_pref("ldap_2.servers.pab.uid", "04b413a3-3f12-494a-a49a-ac6cacdeea6e");

The autocompletequery formats match up with what Toad-Hall posted.

I checked Preferences to make sure that I was checking the Local Address Book for autocomplete.

Modified by ska.adley

more options

many thanks ska.adley

I gave up on Thunderbird. No one was able to solve it; Mozilla has had this problem and steadfastly refuses to fix it. So I deleted TB on my systems and went back to what I was using a few years ago B4 the switch.

Namely, it is " The Bat!" email program.

Now all is well and I have, again, a program that has my address book, etc.

more options

ska.adley The problem with going from beta to 78 was that all the address books got backed up as sqlite files with a v2 in the name, so those filenames would need to get edited to be able to work in 78*. Loads of info on that within the comments. But it meant the original eg: 'abook.sqlite' used in 78* was now backed up and renamed as 'abook.v2.sqlite' and the current 'abook.sqlite' would be only usable in the beta version you had previously used.

Exit Thunderbird

  • Remove all the *.mab.bak files eg: abook.mab.bak to a desktop folder.
  • Remove all the *.sqlite (not if they have a v2 in the name) to a desktop folder.
  • Rename all the *.v2.sqlite files, so removing the v2 eg: abook.v2.sqlite renamed as abook.sqlite

Start Thunderbird. This should work.

The other problem was getting rid of duplicates, which you may not suffer from same.

If all working then do not bother with the next bit: Please check the 'Config Editor' for this line and report back on what you have:

  • ldap_2.autoComplete.directoryServer; - is it set as 'Default', Type = String

if you have eg: set as Boolean Right click on line and select 'Reset'

  • mail.enable_autocomplete should be set as 'true'

If you have these preferences: "mailnews.send.jsmodule" and "mailnews.smtp.jsmodule" please set them to false.

After making changes restart Thunderbird.

Modified by Toad-Hall

more options

The original postee had complicated the matter by adding old address books back in the hope it would fix. They needed to get rid of all the duplicates they had added, but I'm not sure if this was actually done. If one address book is wrong, it messes it up for all.

more options

I had one file named .v2.sqlite. After moving all the other abook files to the desktop, I renamed that file to abook.v2.sqlite.

Started Tbird but no joy; it still didn't autocomplete.

Please check the 'Config Editor' for this line and report back on what you have:

   ldap_2.autoComplete.directoryServer; - is it set as 'Default', Type = String 

It is set as Default, type=String but there is no Value listed.

mail.enable_autocomplete is set to True.

I don't find the two prefs "mailnews.send.jsmodule" and "mailnews.smtp.jsmodule"

Modified by ska.adley

more options

I checked pref.js and found this:

user_pref("ldap_2.servers.pab.uid", "04b413a3-3f12-494a-a49a-ac6cacdeea6e");

(There was just the one ldap_2 server line.)

How is this related to the autocomplete directory Server data in the config editor?

Modified by ska.adley

more options

re :After moving all the other abook files Please post an image showing all those files which you moved.

re :I had one file named .v2.sqlite........ I renamed that file to abook.v2.sqlite. If that file named .v2.sqlite. was already called 'abook.v2.sqlite', then it need to be renamed as 'abook.sqlite'. Please check you got that correct. You would need to exit Thunderbird before renaming file.

And there should have been at least one other file called 'history.v2.sqlite' which would need to be renamed as 'history.sqlite', so it's odd that one is missing.

re : user_pref("ldap_2.servers.pab.uid", "04b413a3-3f12-494a-a49a-ac6cacdeea6e"); That pab (PersonalAddress Book) would refer to the abook.sqlite file (originally called abook.v2.sqlite which you should have renamed as abook.sqlite)

But it is odd that there was only the one line as I would have expected there to be another similar line for the 'history.sqlite' file.

more options

Sorry, that was a typo about renaming abook.v2.sqlite. I did rename it abook.sqlite.

There is a history.sqlite in the active profile now. I downgraded from beta 86.01b. This was back in February. Afterwards, I found no addresses in my Personal Address Book.

I had the following address files listed in the old active profile which I saved a copy of right after the downgrade. abook.mab.bak abook.sqlite abookv2.sqlite history.mab.bak [there was no data in this file.] history.sqlite history.v2.sqlite

I filed a request for assistance with this and got no feedback. After a week, before I changed anything, I used a database browser to check the sqlite and v2.sqlite files and they had my data in them. It appeared to me that Tbird couldn't find the correct abook file for some reason.

So I renamed all the sql files putting an X or Y at the front (see the image), then renamed abook.mab.bak to abook.mab and started Tbird up again and then I had all my addresses but autocomplete didn't work. I've been starting all mesages from the Address Book ever since. I finally found this report and added my remarks because the autocomplete issue is the same. Too bad I didn't know about the different sql formats then. I might have done things differently. The problem remains the same though. Tbird can't find that abook.sql when it needs to do an autocomplete and the question is why.

Modified by ska.adley

  1. 1
  2. 2