Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why I Keep getting Logged out

  • 5 replies
  • 1 has this problem
  • Last reply by cor-el

more options

If you tried to redirect me to https://support.mozilla.org/en-US/questions/1319622 Then I will say that I didn't find out the option:- •Turn off Always Use Private Browsing Mode •Turn on Remember My Browsing And Download History •At the bottom of the page, turn on Clear History When Firefox Closes. •At the far right, press the Settings button. •Turn on ONLY Cache and Form And Search History leaving the others off.

Attached screenshots

All Replies (5)

more options

Hello Vaibhav,

To easily find that option go to about:preferences from the URL address.

And on the top search for always use private browsing.

Check my screenshot for details.

Modified by Μάριος

Helpful?

more options

Detail like websites remembering you and log you in automatically is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions/Permissions"

Helpful?

more options

This is my own custom

Modified by Vaibhav Kushwaha

Helpful?

more options

And i pretty much got you You wanted to disable the Private Browsing Mode So, that auto clearing will may stop but it doesn't I wanna say that It is not always when I Launch Firefox But It happens Rarely

Helpful?

more options

What are the settings further up under "Cookies and Site Data" ?

  • Options/Preferences -> Privacy & Security -> Cookies and Site Data

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.