Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps me logging out from a website after re-opening the browser.

  • 1 reply
  • 1 has this problem
  • 125 views
  • Last reply by FredMcD

more options

After re-opening firefox it logs me out automatically where I previously logged in during my last session. I have checked that cookies auto-delete is turned off in settings. And privacy is selected as "Standard". I am attaching a screenshot of current add-ons which are installed. Note that I do not use container tabs except for facebook container. And I am aware of all the features of container tabs. Is there any solution? OS: Windows 10 Home and using Firefox (stable version)

Attached screenshots

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

and whatever else you want.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file.

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

and whatever else you want.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.