Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Two-sided printing rotating on wrong axis

  • 6 replies
  • 1 has this problem
  • 361 views
  • Last reply by jscher2000

more options

How can I set two-sided printing to rotate on the long axis (so both sides are printed in the same direction, and when you turn the page you can keep reading easily)? With the new upgrade it keeps defaulting to printing on the short axis (so the second side is printed upside down) which makes it very difficult to read smoothly. This has always been easy to set previously. Now the Print menu only allows you to toggle Two-Sided Printing on and off, not to choose the axis. The system dialog does include this setting, in theory, but it doesn't work. I have tried changing it to Long-Edge Binding several times. Each time I change the setting and print immediately, and it still prints with Short-Edge Binding which I do not want. Help! If this can't be fixed I will need to stop using two-sided printing entirely, which will mean wasting a lot of paper.

Attached screenshots

Chosen solution

This seems to be related to a problem we had in Firefox 85 where we mapped long&short edge incorrectly. It was recently fixed in Firefox 86. I'd encourage you to update to the latest version and see if this fixes your problem.

Read this answer in context 👍 0

All Replies (6)

more options

I thought Firefox used the default settings for the printer rather than sending specific settings, but that could be different now. Is there any way to save the long edge setting in that Printer Properties dialog so it can't reset to short edge?

more options

That's what I'm trying to find out. I tried changing it to long edge but every time I closed the dialog box it reverted back to short edge.

Modified by elkatd

more options

Chosen Solution

This seems to be related to a problem we had in Firefox 85 where we mapped long&short edge incorrectly. It was recently fixed in Firefox 86. I'd encourage you to update to the latest version and see if this fixes your problem.

more options

That worked! Thank you so much!

more options

This is really irritating and upsetting my ability to work. I have Firefox 86 but still do not have duplex printing - the second page prints upside down. Do I need to use an alternative browser?

more options

martin210 said

I have Firefox 86 but still do not have duplex printing - the second page prints upside down.

The second page prints upside down on a separate piece of paper?

(A) Duplex Setting

You can switch between short-edge and long-edge binding manually if needed:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste duplex and pause while the list is filtered

Firefox should list the print_duplex value for each printer. Printers you have not yet used in the new print experience will have a weird number that is not on this list:

  • 0 => print single-sided
  • 1 => print double-sided, with long-edge (portrait mode left-right) binding
  • 2 => print double-sided, with short-edge (portrait mode top-bottom) binding

To edit a value, double-click the current value to display an editing field. Change it as you wish, then press Enter or click the blue check mark button to save the change.

(B) If the Printer does not comply

You might need to use the "Print using the system dialog" link at the lower right (see attached screenshot).