Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Page links on NEW TAB are gone

more options

My homepage is set to AOL. The "Open New Tab" used to display 6 or 7 webpage links I could click on instead of diving into my bookmarks. I clicked on a small button in the upper corner and after making a few changes. Now the new tab is totally blank. Would like to restore the original setting without uninstalling and re-installing Firefox.

Chosen solution

I downloaded Malware Fox AntiMalware and it ran a full system check. It did flag the Aquarium Lite addin from Facebook but I think that was because it was adware. Anyway I accidentily had it clean the app BUT on the plus side I still have the bookmarks toolbar and the "Other Bookmarks" icon. Essentially I have restored the functionality I lost.

I do miss the aquarium but it had a very large "search box" that I found VERY annoying.

Read this answer in context 👍 0

All Replies (5)

more options

I tried REFRESHING Firefox and after about 10 minutes it finished. The Frequent Sites on the NEW TAB are still gone. They were there briefly again but disappeared. All the bookmarks are still there when I go into SHOW ALL BOOKMARKS. Also now the folder icon OTHER BOOKMARKS is gone.

Helpful?

more options

Sorry to hear your Refresh did not work correctly. As the first step, could you do a result shutdown and restart of Windows 7 to release any locked files that may be preventing Firefox from showing your bookmarks.

Then after that, you might consider bringing back your old profile from before the refresh. I'm providing a step-by-step link for that. Note that even though it refers to Windows 10's File Explorer, the Windows 7 explorer is nearly identical.

https://support.mozilla.org/en-US/questions/1322197#answer-1384732

Once you have your old profile up and running we can resolve why the Top Sites section of the new tab page isn't appearing. You could check the settings section here:

Hide or display content in New Tab

Helpful?

more options

I was able to work around the problem without applying the changes you suggested. I downloaded an aquarium app from Facebook that gave me back the "Other Bookmarks" folder plus a menu bar for holding bookmark favorites. I still don't have the "gear" icon but so far I'm not missing it.

Helpful?

more options

An app from Facebook? Are you sure it's trustworthy?

Helpful?

more options

Chosen Solution

I downloaded Malware Fox AntiMalware and it ran a full system check. It did flag the Aquarium Lite addin from Facebook but I think that was because it was adware. Anyway I accidentily had it clean the app BUT on the plus side I still have the bookmarks toolbar and the "Other Bookmarks" icon. Essentially I have restored the functionality I lost.

I do miss the aquarium but it had a very large "search box" that I found VERY annoying.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.