Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Translate web page is not displaying properly.

  • 3 replies
  • 1 has this problem
  • 133 views
  • Last reply by Kev

more options

It's been a while since I last used Firefox, so I'm assuming a compatibility issue with a recent browser update is what's causing the Google Translate site to not load properly (see attached picture). What can I do to fix it? Thanks in advance!

Attached screenshots

Chosen solution

Your Firefox isn't showing the "Material Icons" font for some reason. That loads from this URL:

https://fonts.gstatic.com/s/materialiconsextended/v64/kJEjBvgX7BgnkSrUwT8UnLVc38YydejYY-oE_LvJ.woff2)format('woff2');

Why might the Material Icons font not be loading? There are many possible reasons, but here are some common things to check, the details follow:

(1) Font setting -- are pages allowed to specify fonts to use? (2) Is an add-on or preference blocking downloadable fonts?

For #1, go to the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2:

Add-ons

Some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts".

No Downloadable Fonts Preference

There's a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference has a value of false, double-click it to restore the default value of true

Was it any of those things?

Read this answer in context 👍 1

All Replies (3)

more options

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore

Helpful?

more options

Chosen Solution

Your Firefox isn't showing the "Material Icons" font for some reason. That loads from this URL:

https://fonts.gstatic.com/s/materialiconsextended/v64/kJEjBvgX7BgnkSrUwT8UnLVc38YydejYY-oE_LvJ.woff2)format('woff2');

Why might the Material Icons font not be loading? There are many possible reasons, but here are some common things to check, the details follow:

(1) Font setting -- are pages allowed to specify fonts to use? (2) Is an add-on or preference blocking downloadable fonts?

For #1, go to the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2:

Add-ons

Some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts".

No Downloadable Fonts Preference

There's a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference has a value of false, double-click it to restore the default value of true

Was it any of those things?

Helpful?

more options

Thank you jscher2000. It was the font setting that needed fixing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.