Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

issue with "greyed out" add-ons, which cant be used untill add-on is re-enabled in settings.

  • 3 replies
  • 1 has this problem
  • 21 views
  • Last reply by FredMcD

more options

Hey firefox community,

I have an issue where certain add-ons are not loading their icons (greyed out), and after a computer shutdown, or simply closing the window, the icons don't seem to stay in the overflow menu (or the place where you can store addons if you don't want them on the toolbar or the overflow menu). my only option to be able to use the extension is to "re-enable" the extension from the add-on menu.

I've read somewhere on a support thread that it may have something to do with adblockers, and although I do have adguard, I'm not 100% sure if that's the issue, as I tried disabling adguard when loading firefox, and I seemed to only be able to load the add-ons correctly once, but not again (to be fair, not a lot of testing went into this hypothesis or test).

if there is some kinda issue with adguard, I would love to know what I need to do to solve this issue, and if its something else, I would also love to know what else I would need to do, short of a clean install of firefox or something similar, as I have a few add-ons with custom settings, and resetting all of that would be a pain to redo.

thanks for your help.

PS, any additional info needed can be sent over, just may take some time

Attached screenshots

Chosen solution

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

more options

thanks FredMcD,

the solution wasn't a complete fix, and I had to do a browser reset to get everything to work, have a weird side effect of an extension not working quite right, but I think that's more of a full reinstall kinda issue.

thanks for looking into the issue anyways, Tim

more options

Glad to help. Safe Surfing.