Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

set "print with system dialog" as default

  • 7 replies
  • 8 have this problem
  • 5921 views
  • Last reply by schmidtenor

more options

dear ladies and gentlemen,

Firefox has been delivered with the new print dialog since version 82.

I have to print around a hundred PDF files at work (usually only the first page of the document). The new print dialog means that there is a lot more work for me here.

Is it possible to set the "old" system print dialog by default or to instruct firefox to always print only the first page of the document by default?

Chosen solution

For now you can flip a pref on the about:config page to revert to the old print dialog.

  • print.tab_modal.enabled = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Read this answer in context 👍 8

All Replies (7)

more options

Chosen Solution

For now you can flip a pref on the about:config page to revert to the old print dialog.

  • print.tab_modal.enabled = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

cor-el said

For now you can flip a pref on the about:config page to revert to the old print dialog.
  • print.tab_modal.enabled = false
You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Hello and thank you for your answer.

flip the pref helped.

Thank you and have a nice day!

more options

Thanks VERY MUCH! Show me the focus group that thought the new print dialog is an improvement. NOT! Difficult to scale, no memory of last print prefs, etc. DUMP IT!

more options

I too have switched off the unnecessary and time-wasting print.tab_modal dialog. It is an irritating extra step in printing to .pdf, and I request that a check-box or switch be added to disable it without having to go into the about:config page.

more options

So frustrating . It keeps reseting itself to this new, terrible, print interface. Why reinvent the wheel? Such a waste of programmer effort. There's a perfectly good, better print interface with Windows.

more options

I presume this was added to align more with the Chrome feel and their now almost 60% browser dominance? One of the reason I do not use chrome is their print dialogue and I still prefer FF over-all.

Thank you for the config help and I, too, vote for a preference-level setting as I prefer the native Mac dialogue and the "print/save as PDF" functionalities.

more options

Thank you! This was driving me nuts. Changed the pref to "false" and that seems to have fixed it. For now.