Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to enable spell-check permanently?

more options

Spell-checking is working perfectly but whenever I type I have to click this check spelling button every time (See the screenshot) or else the spell check doesn't work. Is there any way to turn it on permanently?

All Replies (6)

more options

Badruzzaman Nibir said

Spell-checking is working perfectly but whenever I type I have to click this check spelling button every time (See the screenshot) or else the spell check doesn't work. Is there any way to turn it on permanently?

Sorry I forgot to add the screenshot :( So I am attaching here.

Helpful?

more options

Is this with all websites/pages, some, a few?

Some websites use their own spellchecker and shut down the browsers.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Helpful?

more options

Grammarly for Firefox by Grammarly https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/

Grammarly will help you communicate more effectively. As you type, Grammarly flags mistakes and helps you make sure your messages, documents, and social media posts are clear, mistake-free, and impactful.

Helpful?

more options

FredMcD said

Is this with all websites/pages, some, a few? Some websites use their own spellchecker and shut down the browsers. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

The in built spell checker works but the problem is that I have turn it on every time I type by clicking on Check spell. I have to do this for every site like here as well.

Helpful?

more options

What is the setting in "Options/Preferences -> General -> Language and Appearance -> Language" ?

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

Helpful?

more options

cor-el said

What is the setting in "Options/Preferences -> General -> Language and Appearance -> Language" ? You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

The language which is selected is English (US)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.