Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Block video popups

  • 4 replies
  • 4 have this problem
  • 150 views
  • Last reply by firelight

more options

Many sites have videos playing when I open the page. If I just ignore the video and scroll down without explicitly stopping the video, I get a popup window playing the video. Apparently the popup blocker doesn't consider this to be a popup. Is there any way to kill this annoying behavior?

Chosen solution

Change autoplay in permissions setting to block audio and video. These are not "popups", firefox pop out video player.

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

Change autoplay in permissions setting to block audio and video. These are not "popups", firefox pop out video player.

Helpful?

more options

That works. Thank you.

Helpful?

more options

This does not work for me. Videos follow me down the page in the sidebar. Often blocking some of the text. Are there about:config settings I can use? Addons? Anything?

Helpful?

more options

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Helpful?

more options

Thanks cor-el. It works better, especially in stopping autoplay on pages.

But popup videos still follow me down the sidebar on some pages. For example; on space.com pages such as this one: https://www.space.com/antarctic-ice-shelf-collapse-as-earth-warms

Also, can I add exceptions to the autoplay settings in Firefox options: Tools menu > options > Privacy and security > Permissions > Autoplay > Block audio and video. I would like to add an exception for Youtube playlists. To allow autoplay on them.

There is a box there. I am not sure what the box there does. I can't enter anything into it.

I am confused about popup videos mentioned lately every time Firefox updates. That apparently is a feature. But I saw no mention or link about how to turn them on or off.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.