Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird is always asking for me to enter my password

  • 4 replies
  • 1 has this problem
  • 20 views
  • Last reply by cajig

more options

Since the last 2 Thunderbird updates (using 78.5.0) over the last 6 weeks TB will not send email. Continually ask for my password which I input and check the "Password Manager to remember" box but that makes no difference. After trying to send email several times and entering password I save the email msge to my drafts folder. I leave it for 10-15 minutes, open that email out of drafts and it sends without asking for the password. My ISP is Iprimus.com.au and I have checked using the webmail function and eveything works ok. I have checked both the incoming and outgoing server settings and they are correct as to Iprimus's configuration requirements for TB My Pc system is running Win 10 Home a 64 bit system, Version 1909, Build 18363/1198 running. I have been using TB for about 8 years now and this has only occurred within last 2 months. Any solutions?

Chosen solution

Make a note of your passwords then try recreating the entire password storage.

  • Menu app icon > Help > Troubleshooting Information
  • Under Application Basics' section locate - Profile Folder and click on 'Open Folder'
  • close Thunderbird now.
  • delete these files:
  1. cert9.db
  2. key4.db
  3. logins.json

These will get created again after starting thunderbird.

Start Thunderbird.

Enter correct passwords at prompt and select checkbox to remember them so we be sure all is working correctly.

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Make a note of your passwords then try recreating the entire password storage.

  • Menu app icon > Help > Troubleshooting Information
  • Under Application Basics' section locate - Profile Folder and click on 'Open Folder'
  • close Thunderbird now.
  • delete these files:
  1. cert9.db
  2. key4.db
  3. logins.json

These will get created again after starting thunderbird.

Start Thunderbird.

Enter correct passwords at prompt and select checkbox to remember them so we be sure all is working correctly.

Helpful?

more options

Thanks Toad-Hall, Have followed your instruction. Appears to be working at the moment I guess time will tell

Helpful?

more options

Hello Toad-Hall, TB is sending better, only 2 or 3 'sends' necessary for messages to be sent now on most occasions. On the odd occasion I need to save the message to draft after trying to send, then up to 3 or 4 'sends' and the message goes. I have followed your instructions again although I noticed the following: I do not have a cert9.db file but have a cert8 (created 26-11-2018) and cert9 file (created 17-02-2021). I have deleted only the cert9 file, I also do not have a key4.db file only a key4. file have deleted the key4 file, I do have a logins.json file which I have deleted.

Once again seems to be working at the moment Thanks cajig

Helpful?

more options

Hello Toad-Hall Well followed all the instructions to the letter. TB then works for a while, a couple of hours or even a couple of messages and reverts to the same old. Several attempts to send message with TB asking for password and still not sending. Save message to "Draft" and message finally sends after several attempts. Additional to all of the above, I have also followed the instruction to delete the pkcs11.txt file. Any further suggestions. cajig

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.