Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird V78 problem in MacOS Big Sur

  • 22 replies
  • 4 have this problem
  • 605 views
  • Last reply by Wayne Mery

more options

Dear Thunderbird and all: When will have Version of Thunderbird fit for MacOS Big Sur? Now, use Version 78.4.3 is big problem in MacOS big sur, that start Thunderbird would be waiting loooooooooog time, when thunderbird show all emails, then scrolling is lag(delay) without , dear all, do you know how resolved this problem? I had try uninstall, reinstall, I had try everything what I can do. Thanks, if you have same problem with best solution to solve problem, please ,please let me know. I am really appreciate . thank you for your urgent reply.

Best Regards! Michael.

Chosen solution

Please do Help > About to get version 78.6.1, and tell us the results. Thanks.

Read this answer in context 👍 0

All Replies (20)

more options

Helpful?

more options

Wayne Mery said

This is https://bugzilla.mozilla.org/show_bug.cgi?id=1677272 No solution ... yet

Hi Wayne Mery: Thanks your reply and explanation .I had read your share linked, you are very kindly. Full understand and waiting Thunderbird updates new version for Big Sur. Thanks again Wayne Mery.

Best Regards! Michael

Helpful?

more options

Today, I updates to 78.5.0 , it is no use too. keep lag(delay) with opening and scrolling all emails. Worst experience with Thunderbird first time. Try.............

Helpful?

more options

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

Helpful?

more options

yanglongfei908 said

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

Thanks yanglongfei, I will try to install beta version. thanks again. Have a nice day!

Helpful?

more options

yanglongfei908 said

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

This would surprise me. Beta 83? Or beta 84?

Helpful?

more options

Just now, I try to click download beta version, but there is 84 only , I am not sure 83 can choose. this would surprise me too. Wish beta version working on my Big Sur smoothly.

Helpful?

more options

Wayne Mery said

yanglongfei908 said

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

This would surprise me. Beta 83? Or beta 84?

Hi Wayne Mery, I had install beta version , It does working for my Big Sur with my 11 email accounts add already. It worked smoothly as same as Catalina before. Maybe you would try it. Hope your device become good as well.

Helpful?

more options

yanglongfei908 said

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

Hi yanglongfei, thanks again. It works for me with beta version on my Big Sur. thank you!

Helpful?

more options

Wayne Mery said

yanglongfei908 said

Same problem. I downloaded and installed the beta version then it's solved. It seems there is sth wrong with the stable version.

This would surprise me. Beta 83? Or beta 84?

I installed 84.0b1, the latest one.

Helpful?

more options

I have even worse problem on Big Sur. If I startup my iMac and wehen it booted up start Thunderbird immediately - it hangs forever. When it goes into this mode, it is impossible to ever start it up again - it just hangs. I have to restore my mail folders and Library/Thunderbird from backup. When I restart my iMac and wait for about 5 minutes after booting up and then start it - it works just fine. BTW, I have zero extensions installed - addons show only standard Thunderbird themes.

It looks to me as though Thunderbird gets into a state competing with MacOS processes for something and it cannot recover. Looking at it in Activity Monitor shows insane amount of threads being spawned (700 and up) and no CPU being used - when examined in Activity Monitor lots of threads are waiting for some kind of lock.

This is happening for all v78.x. I am on 78.4.3 - found that it gets me into that hanged state least of all (78.5 is the worst).

I am also using Firefox and it works absolutely fine so the problem localized to Thunderbird.

Any insights would be greatly appreciated. I sent all forced kill dumps to Apple Dev support.

Modified by alexey.danilchenko

Helpful?

more options

alexey.danilchenko said

I have even worse problem on Big Sur. If I startup my iMac and wehen it booted up start Thunderbird immediately - it hangs forever. When it goes into this mode, it is impossible to ever start it up again - it just hangs. I have to restore my mail folders and Library/Thunderbird from backup. When I restart my iMac and wait for about 5 minutes after booting up and then start it - it works just fine. BTW, I have zero extensions installed - addons show only standard Thunderbird themes. It looks to me as though Thunderbird gets into a state competing with MacOS processes for something and it cannot recover. Looking at it in Activity Monitor shows insane amount of threads being spawned (700 and up) and no CPU being used - when examined in Activity Monitor lots of threads are waiting for some kind of lock. This is happening for all v78.x. I am on 78.4.3 - found that it gets me into that hanged state least of all (78.5 is the worst). I am also using Firefox and it works absolutely fine so the problem localized to Thunderbird. Any insights would be greatly appreciated. I sent all forced kill dumps to Apple Dev support.

Hi alexey: I reinstall Beta Version, that solved problem with normal use as choose emails ,scrolling with smoothly.But also, when I close and start APP again. always keep waiting long time( This problem always exist,I always keep APP keep open status.), Second, I can not click Combine Inbox, When I click, also stop , would be waiting 2 mins become using status. these are Beta version real situation on Big Sur when I use Beta Version.

Others: there is another bug as well. When I open new email and delete this new email, that will show wrong number on Today's amount. such as normally is (Today 5/30) 5 is unread, 30 is total of today. Wrong show like this: (4294967295/29) 4294967295 is unread. 29 is totally.

Helpful?

more options

alexey.danilchenko said

I have even worse problem on Big Sur. If I startup my iMac and wehen it booted up start Thunderbird immediately - it hangs forever. When it goes into this mode, it is impossible to ever start it up again - it just hangs. I have to restore my mail folders and Library/Thunderbird from backup. When I restart my iMac and wait for about 5 minutes after booting up and then start it - it works just fine. BTW, I have zero extensions installed - addons show only standard Thunderbird themes. It looks to me as though Thunderbird gets into a state competing with MacOS processes for something and it cannot recover. Looking at it in Activity Monitor shows insane amount of threads being spawned (700 and up) and no CPU being used - when examined in Activity Monitor lots of threads are waiting for some kind of lock. This is happening for all v78.x. I am on 78.4.3 - found that it gets me into that hanged state least of all (78.5 is the worst). I am also using Firefox and it works absolutely fine so the problem localized to Thunderbird. Any insights would be greatly appreciated. I sent all forced kill dumps to Apple Dev support.

alexey.danilchenko said

I have even worse problem on Big Sur. If I startup my iMac and wehen it booted up start Thunderbird immediately - it hangs forever. When it goes into this mode, it is impossible to ever start it up again - it just hangs. I have to restore my mail folders and Library/Thunderbird from backup. When I restart my iMac and wait for about 5 minutes after booting up and then start it - it works just fine. BTW, I have zero extensions installed - addons show only standard Thunderbird themes. It looks to me as though Thunderbird gets into a state competing with MacOS processes for something and it cannot recover. Looking at it in Activity Monitor shows insane amount of threads being spawned (700 and up) and no CPU being used - when examined in Activity Monitor lots of threads are waiting for some kind of lock. This is happening for all v78.x. I am on 78.4.3 - found that it gets me into that hanged state least of all (78.5 is the worst). I am also using Firefox and it works absolutely fine so the problem localized to Thunderbird. Any insights would be greatly appreciated. I sent all forced kill dumps to Apple Dev support.

Hi alexey: I reinstall Beta Version, that solved problem with normal use as choose emails ,scrolling with smoothly.But also, when I close and start APP again. always keep waiting long time( This problem always exist,I always keep APP keep open status.), Second, I can not click Combine Inbox, When I click, also stop , would be waiting 2 mins become using status. these are Beta version real situation on Big Sur when I use Beta Version.

Others: there is another bug as well. When I open new email and delete this new email, that will show wrong number on Today's amount. such as normally is (Today 5/30) 5 is unread, 30 is total of today. Wrong show like this: (4294967295/29) 4294967295 is unread. 29 is totally.

Helpful?

more options

To Michael.O Your reply to alexey.danilchenko was held for moderation. I released it.

Helpful?

more options

Thanks Michael.O.

Strange thing is when 78.4.3 or 78.5 starts - it works fine and fast. It is getting it to do that is the problem. And for me once it gets into that hangin state - it stays there. I waited for half an hour for it to start up and nothing happened. All it does is completely screws up the mailboxes so I need to restore them from backup after.

The only solution for me at the moment is to stay with 78.4.3 (it does it the least of all - 78.5 seems to get stuck more often) and wait for about 5-10 mins after iMac botted up before starting up Thunderbird.

I looked it the snapshot of running application in Activity Monitor and most of those threads spawned are locked on something so it looks like some kind of awful deadlock. Not being a Thunderbird developer it's hard for me to say what is it waiting for or why does it need to run excessive amount of threads on start but clearly something that Thunderbird developers need to address.

Helpful?

more options

Hi Alexey: Thanks your message for me. me too, always met difference problem on Big Sur. I have no idea we can do something . maybe we should be waiting new version for Big Sur matched. I really difficult to drop and change thunderbird to use another APP instead. Good Luck!

Helpful?

more options

Michael.O said

maybe we should be waiting new version for Big Sur matched. I really difficult to drop and change thunderbird to use another APP instead.

I don't think Big Sur is a problem here. So far I have only Thunderbird exhibit this behavior - no other apps do it. To me - that is a sloppy development. Thunderbird developers should really fix that.

Modified by alexey.danilchenko

Helpful?

more options

If you want to be a brave early adopter of an OS then you will need to be brave with the pain - it's not even officially supported yet by Firefox and Thunderbird.

What language/locale are each of you running?

Modified by Wayne Mery

Helpful?

more options

https://discussions.apple.com/thread/252041994?page=2 describes imap response/timeout issues caused by Little Snitch and Avast

https://bugzilla.mozilla.org/show_bug.cgi?id=1677272 describes display slowness

https://bugzilla.mozilla.org/show_bug.cgi?id=1677380 describes a rare Mac address book issues

Do one of these match your problem?

Helpful?

more options

Wayne Mery said

If you want to be a brave early adopter of an OS then you will need to be brave with the pain - it's not even officially supported yet by Firefox and Thunderbird. What language/locale are each of you running?

With that approach even Catalina is not supported yet - judging by amount of complaints of startup slowness. It does happened to me on Catalina (taking ages to start) but nit to the point of completely hogging the application. In any case the synptoms do beg the question - why on earth Thunderbird needs to spawn so many processes on startup locking on something?? This should not be the case for email client regardless of OS version.

My locale is English - UK.

Modified by alexey.danilchenko

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.