Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New tab page is completely blank

  • 7 replies
  • 1 has this problem
  • 46 views
  • Last reply by elzach

more options

New tab displays absolutely zero content, no top sites, no settings wheel. I went to "about:config" and I saw some false values under "browser.newtabpage". I changed them to true. See attached. Still that didn't work. Notice there is a curious "browser.newtabpage.blocked" string (mercy!)

Never had this problem before with any other version. I see some people had the same problem with v. 60.

Thank you for any suggestions.

Attached screenshots

All Replies (7)

more options

Hi Elzach,

Have you tried starting Firefox in Safe Mode? If you haven't, you can find the steps here:

Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu , click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. If this doesn't help, let me know and we can keep troubleshooting your issue.

Helpful?

more options

Thanks, but same issue with safe mode.

Please take a look at attached screenshot, what's this "browser.newtabpage.blocked" with a string value?

Obviously this is a big concern. The new tab page with my top sites is my starting point basically. Could something be corrupted in my profile folder?

Helpful?

more options

Have you tried the fix proposed here?

https://support.mozilla.org/bm/questions/1057798

Helpful?

more options

That thread is from 2015. It no longer applies, there's no "reset" of browser.newtabpage.enabled. It's "true" or "false".

Helpful?

more options

If someone has any other suggestion I'd appreciate it. This is a rather complicated issue. The background is that I downgraded from v. 68ESR to v. 60ESR. It didn't ask me to create a new profile, but I had backed up the entire profile any way. Now, one curious thing, even though it downloaded and installed 60ESR with no problems, it kept the original profile with the same name, it didn't assign it a new name, as I've seen in all cases before.

Again, I didn't have this problem with v 68ESR, or any other version for that matter.

I just did the following, I created a new profile and copied all the contents from the 68ESR profile, and loaded FF with that new profile. Same result, completely blank new tab page. So the problem might be more "sinister" than thought at first.

Helpful?

more options

Hi Elzach, one other question - is it possible that during that downgrade (or at another time) FF has turned on the "blank page" setting in about:preferences? Under the home tab, New Tab should be set to "Firefox Home (Default)". If it is set to "Blank Page", the new tab page shows as you have described it above - no content, sites, or settings wheel.

Of course, I understand your concern that there are other issues at play. Often, the simplest answer is the one that works, which I why I'm asking these other questions. If you have no luck with this, I'll see if we can get one of our more experienced contributors to have a look.

Helpful?

more options

Thanks Emily. No, I checked that, my home page hasn't changed. In any event, I found an "indirect" solution. I installed a simple new tab extension (from the many listed) that shows me my most visited sites (albeit only 9) plus some nice wallpaper photos, every time I click on a new tab. So we can consider this issue closed for now.

Emily said

Hi Elzach, one other question - is it possible that during that downgrade (or at another time) FF has turned on the "blank page" setting in about:preferences? Under the home tab, New Tab should be set to "Firefox Home (Default)". If it is set to "Blank Page", the new tab page shows as you have described it above - no content, sites, or settings wheel. Of course, I understand your concern that there are other issues at play. Often, the simplest answer is the one that works, which I why I'm asking these other questions. If you have no luck with this, I'll see if we can get one of our more experienced contributors to have a look.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.