Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site icons

  • 2 replies
  • 1 has this problem
  • 42 views
  • Last reply by cor-el

more options

About 10% of my bookmarks show the generic globe icon rather than the site-specific icon, even after I have visited the site. The icons display fine when I visit the site with Chrome. Is there a fix for this?

About 10% of my bookmarks show the generic globe icon rather than the site-specific icon, even after I have visited the site. The icons display fine when I visit the site with Chrome. Is there a fix for this?

All Replies (2)

more options

Open your Firefox profile folder and delete the favicons.sqlite file. Make sure that Firefox is closed when you do this.

When you open Firefox again, all of your bookmarks will have the generic globe icon, but they will be replaced with the proper icon when you visit them. If you don't want to open each bookmark manually, you can use the Checkmarks add-on.

Hope this helps.

more options

See also this extension: