Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Installation questions: won't override serif fonts; bookmarks not showing in toolbar; all icons identical

more options

Just installed the latest version of FF (82). Couple of questions I don't see answered in the knowledgebase:

- I have all the font settings set to Arial or sans serif. However, some webpages, such as the NY Times, still show up in a serif font. How do I override that?

- My bookmarks aren't showing on the Bookmarks toolbar--it's blank. (I imported them in HTML from another browser.) The toolbar is on, but no bookmarks. Anyone know why?

- The bookmark icons are all the same gray circle. They change to the appropriate icon for the site if I click on them, but I can't click on all of my hundreds or thousands of bookmarks. Any way to get them to show the correct icon for each site?

Thanks.

Chosen solution

Firstly, for the font issue, I assume that you probably have the Allow pages to choose their own fonts, instead of your selections above option checked in the font settings. This will allow the website to ignore your font settings and load its own font. Unchecking that option should use the fonts that you want.

As for the icon issue, this is because the icons are not saved in your bookmark backups or when the bookmarks are imported from Firefox Sync. They would increase the size of the backup and if you were to have a backup from years ago, the icon could be really outdated.

As you've already pointed out, Firefox does reload the icon the first time that you visit the bookmark. Naturally, it becomes a big task if you have a lot of bookmarks. I often recommend the Checkmark add-on to users looking to restore all of the icons. It will just open all of the bookmarks for you automatically to load the icon, so it's best to run it when it you are not using your computer.

Finally, with regards to the bookmark toolbar, check to see if the bookmarks were put into another folder or subfolder (often the Other Bookmarks folder). This happens sometimes when they are recovered from a backup or when they are imported from another browser.

Hope this helps.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Firstly, for the font issue, I assume that you probably have the Allow pages to choose their own fonts, instead of your selections above option checked in the font settings. This will allow the website to ignore your font settings and load its own font. Unchecking that option should use the fonts that you want.

As for the icon issue, this is because the icons are not saved in your bookmark backups or when the bookmarks are imported from Firefox Sync. They would increase the size of the backup and if you were to have a backup from years ago, the icon could be really outdated.

As you've already pointed out, Firefox does reload the icon the first time that you visit the bookmark. Naturally, it becomes a big task if you have a lot of bookmarks. I often recommend the Checkmark add-on to users looking to restore all of the icons. It will just open all of the bookmarks for you automatically to load the icon, so it's best to run it when it you are not using your computer.

Finally, with regards to the bookmark toolbar, check to see if the bookmarks were put into another folder or subfolder (often the Other Bookmarks folder). This happens sometimes when they are recovered from a backup or when they are imported from another browser.

Hope this helps.

Helpful?

more options

trg12 said

- My bookmarks aren't showing on the Bookmarks toolbar--it's blank. (I imported them in HTML from another browser.) The toolbar is on, but no bookmarks. Anyone know why?

Does your Bookmarks Toolbar show the default item, "Getting Started"? If that isn't there either, you might go into the Customize mode and make sure that a placeholder titled "Bookmarks Toolbar Items" is at the left end of the bar. If that is not on the bar, you could check in the box of unused controls to see whether you can drag it back.

More info: Customize Firefox controls, buttons and toolbars

Helpful?

more options

Wow, Wesley, you got all three--that's great! Thanks! The "Allow pages to choose" box was, in fact, checked--it's at the bottom of the dialog box, and I didn't scroll down far enough to see it. The Bookmarks Toolbar items were in a folder of that name in the regular bookmarks list. I cut and pasted them into the correct folder, and they magically appeared. And finally, that Checkmarks add-on seems to be doing the job. You hit the trifecta and retired the MVP (Most Valuable Poster) award for the night!

jscher, thanks to you too, but I didn't get that far, since Wesley's solutions worked.

Thanks again to both of you for your prompt and accurate responses!

Helpful?

more options

Glad I was able to help :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.