Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video Playback --- New Security Settings Blocking Playback -- FF 82.0.1 & FF 82.0.2

  • 3 replies
  • 1 has this problem
  • 8 views
  • Last reply by jscher2000

more options

Hi Folks, Ever since the recent upgrade to FF 82.0.1 [and still with 82.0.2], I can no longer log-in or watch videos on TCM. https://www.tcm.com/watchtcm.

This site has been allowed in my about:preferences#privacy for many months.

In the first screenshot, you can see [top right] that SIGN IN box is disabled.

I have also attached a screenshot of the Permissions settings for this site.

Anyone have any ideas?

Attached screenshots

Chosen solution

I suppose this is a constant struggle for filtering add-ons to block just the right things without breakage. Maybe they can release an update that strikes a better balance if you let them know about the problem.

Read this answer in context 👍 0

All Replies (3)

more options

Hmm, it's interesting. The initial source code of the page (Ctrl+u) has no text on the button, and it gets filled in by a script as the page is laid out:

<!-- btn content controlled in Auth.js --> <button class="watch-button watch-button--medium watch-navbar__right-container__signin" id="user-auth-btn"></button>

So it seems that something is going wrong during that setup process.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

Hello JScherr, Thanks for your help.

I did take a brief look at the source code and I did find that auth.js intriguing ... it links to the provider for log in verification.

I have the cache set to clear on exit, so I knew in advance that that was not the issue.

Per your recommendation, I ran SAFE MODE and presto, it worked.

I had checked the content blockers particularly AdBlock, but I had not reviewed DDG Privacy. Once I reset this, it worked [see screenshot] ... unfortunately this site uses quite a bit of tracking ... grade dropped from B+ to D after disabling it.

Helpful?

more options

Chosen Solution

I suppose this is a constant struggle for filtering add-ons to block just the right things without breakage. Maybe they can release an update that strikes a better balance if you let them know about the problem.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.