Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

eBay not loading - just blue script

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by rustykate1

more options

Hi, I've read lots of comments about eBay not loading correctly and I have had the same problem for a couple of weeks. Is there any solution? Like the others, I have reinstalled Firefox, cleaned out history and cache and other stuff but it's still a prob. I contacted eBay but no solution. I figured it must be Firefox since eBay is fine with Chrome and Edge (neither of which I usually use). Please help.

All Replies (2)

more options

Earlier this month, numerous users reported that they had to disable Enhanced Tracking Protection on eBay to get the page styled properly. You could try that: click the purplish shield icon at the left end of the address bar, then click the slider switch to turn off ETP. If the page doesn't reload automatically, you can use the reload button in the address bar. Success?

I think this only occurs with "Strict" protection and not "Standard" protection, and perhaps not on all systems.

Helpful?

more options

Hi jscher,

Thanks for your reply. I had already set Enhanced Tracking Protection to 'off'. But I haven't tried the Reload button - thanks. I just tried eBay and it works, but this has happened many times - about one in every ten attempts to open actually works. But I did notice this morning that it wouldn't open in Chrome - that's a first. Edge always works. Not sure what 'strict' and 'standard' protections are. Thanks heaps again for trying to help! Kate

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.