Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

high CPU usage, even with no tabs opened

  • 7 replies
  • 2 have this problem
  • 58 views
  • Last reply by user1418861

more options

Hi Firefox start to take a lot of CPU depending on how many tabs are opened (that is normal of course especially if with flash contents). What is not normal is that CPU will not be released when tabs are being closed, even with one (blank) tab left opened CPU usage is 40%-85% (depending if other process need CPU). Essentially: once Firefox process obtained 80% of CPU you can close tabs but you are fucked the same, now opening new tabs is a pain! Of course restart fix the issue. Is not a matter of addons or updates, Firefox and system (Windows 10) are updated to last version; I feel is something related with flash contents. Is it possible only me experience this?! Regards

Chosen solution

You can check the Firefox Task Manager (about:performance) and about:memory pages.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 👍 1

All Replies (7)

more options

see screenshot, this should fix your issue, you can find that setting under the ff general settings tab. tools/options/general/ scroll all the way down..cheers

Modified by squirell

Helpful?

more options

Now smooths as never before thanks! Crazy a normal user need to know all these settings (For other reading: the setting to tweak is "content process limit:1" while "use hardware acceleration" can be enabled) Hope next firefox updates will not change that option or I will forgot to change back! Thanks again Regards

Helpful?

more options

anytime mate..cheers

Helpful?

more options

CRAZY update: reverted the "content process limit" option (for testing) to default 8 and now fine the same! (Was quite easy to repeat the problem it just needed something like 10 tabs opened, tabs with flash content like youtube, facebook, and then close them). I will keep continue monitoring the situation, for sure changing that option made the trick in somehow!

My system has 12 GB RAM but slow CPU (AMD Phenom II X2) and the problem I had was with the CPU being stucked soon irremediably

edit: the problem came back the next day, now I set the option to 1 or 2 (that is the number of my CPU cores) and perform a deep test

Modified by Boooooo

Helpful?

more options

Chosen Solution

You can check the Firefox Task Manager (about:performance) and about:memory pages.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

more options

Sorry squirell if have to undo the best answer but hope helps others. Today the problem* occurred whatever "Perfomance" configuration so must be elsewhere and thanks to cor-el realized was existing a "firefox task manager" that easily showed the tabs/extensions "Energy Impact" (indeed from windows task manager is not possible to understand that)

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox

In my specific case the issue was with the add-on "IDM Integration Module" (Download files with Internet Download Manager that try to catch all flash/video contents of the page, maybe have a bug something like CPU/memory leak)


  • Once 80% of CPU was granted by Firefox process there was no way to release even closing tabs

Helpful?

more options

squirell said

see screenshot, this should fix your issue, you can find that setting under the ff general settings tab. tools/options/general/ scroll all the way down..cheers

This fixed mine. I was getting constant lock up and freezes in Firefox. I had to reboot the computer to get it back. I gave up on FF and moved to Chrome.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.