On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 81.0.1 not remembering cookies

  • 3 replies
  • 1 has this problem
  • 735 views
  • Last reply by FredMcD

more options

Version 81.0.1 (64-bit) does not remember cookies. I logged in to my email, Facebook, LinkedIn and other sites and chose to remember the browser. When I restart the browser, I have to login again. This happens on all sites with passwords. I tried the sites and restarting Firefox several times with the same results.

I have disabled all tracker blocking, allowing everything through. Enhanced tracking protection is off for the sites. Cookies, etc. are NOT set to delete upon exit. This is new behavior. Earlier versions did not have this problem. Any idea of how to fix this?

Version 81.0.1 (64-bit) does not remember cookies. I logged in to my email, Facebook, LinkedIn and other sites and chose to remember the browser. When I restart the browser, I have to login again. This happens on all sites with passwords. I tried the sites and restarting Firefox several times with the same results. I have disabled all tracker blocking, allowing everything through. Enhanced tracking protection is off for the sites. Cookies, etc. are NOT set to delete upon exit. This is new behavior. Earlier versions did not have this problem. Any idea of how to fix this?

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Modified by FredMcD

more options

Fred, thanks for the help. Clear History When Firefox Closes was set to clear cookies. Your information solved my problem.

more options

Glad to help. Safe Surfing.