Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unuesably Slow, Stops Responding, High CPU useage

  • 6 replies
  • 1 has this problem
  • 40 views
  • Last reply by FredMcD

more options

I've been using Firefox on all my computers for a long time (Windows 10,) great browser.

However, starting today, specifically on my laptop, it's painfully slow (60 seconds to load Google) and very high CPU usage (over 20%.) It regularly stops responding to mouse and keyboard input. I have to kill it with Task Manager. Everything else on the laptop seems fine. I haven't made any changes I'm aware of that could cause this.

As an example, it took over 2 minutes to load this particular page, then at least another 90 seconds before I could type anything into it. My network connection is fine. IE and Edge work OK.

I've tried a Firefox refresh, no change.

An uninstall and reinstall, no change. I've tried a reinstall with also deleting all the appdata folders (so a clean install, no extensions,) no luck.

I've tried disabling antivirus (Symantec, always suspect) no change.

Unless there's something I can remove in the registry I'm at a loss.

I'm really hoping I don't need to switch to Chrome, or God forbid, Edge.

Chosen solution

Hi Fred:

It took a while to track down the culprit. Started with a clean boot (services and apps) and started enabling things from there.

The problematic software is the Nahimic audio app set to run at startup, specifically NahimicMSIUILauncer.exe. I tried to update it but apparently there are other third party driver dependencies that weren't met, it was simpler to disable it.

Thanks for pointing me in the right direction, problem solved.

Read this answer in context 👍 0

All Replies (6)

more options

Final note, (I'm adding this from Firefox on another computer) posting the above message from Firefox on my laptop took well over 10 minutes.

Helpful?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Fred, thanks for the super speedy response!

Firefox in safe mode, same issue.

Windows in safe mode with networking response, issue seems resolved.

I guess I'll have to start digging through my startup items. I have no idea what changed or updated to cause this. All the hardware reports look OK.

Are you aware of any reports of conflicts with Symantec? I have a lot of my startup items and services disabled as is, except for antivirus. I work on it all day, so I try to keep it "tuned up" for speed.

Helpful?

more options

As a test, disable your protection programs.

Helpful?

more options

Chosen Solution

Hi Fred:

It took a while to track down the culprit. Started with a clean boot (services and apps) and started enabling things from there.

The problematic software is the Nahimic audio app set to run at startup, specifically NahimicMSIUILauncer.exe. I tried to update it but apparently there are other third party driver dependencies that weren't met, it was simpler to disable it.

Thanks for pointing me in the right direction, problem solved.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.