Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More


  • 4 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

Hi, I updated Mozilla Firefox to version 81.0 (64 bit) three days ago. I noticed that the functionality of search in the page (Ctrl+F) doesn't work properly. For example, I try to search a word, using the search bar, and the browser doesn't find anything. Mozilla doesn't highlight anything. Why? However, after I close the browser and open it again, the function of search works. I refreshed Mozilla twice and reinstalled, but the problem persists. Can you help me? Thanks.

All Replies (4)

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder.

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux;

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again. This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia


more options

Make sure you haven't enabled some special features like whole words or match case.

The Find bar has find settings for "Highlight All" and "Whole Words" and "Match Case" that are hidden when you use Quick Find. You can open the Find bar via "Edit -> Find" (Ctrl+F) and check these choices.

Related prefs as found on the about:config page.

  • findbar.entireword = false
  • findbar.highlightAll = false
  • accessibility.typeaheadfind.casesensitive = 0

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window


more options

Hey there, I have tried both reinstalling and running safe mode as well as making sure that the findbar options are all turned off and still have this issue. The strange thing is that the problem is only intermittent and I have no way of forcing it to happen. The only solution I have been able to do is to reopen the browser where CTRL+F will work again for a while like OP has stated.

The site is an intranet site where the problem occurs so that might be the issue... but I don't think that is the case.

Modified by NathanLee


more options

Hi NathanLee, when this occurs, does it make any difference if you reload the page bypassing cached files using either:

  • Shift+click the Reload button
  • Ctrl+F5
  • Ctrl+Shift+r


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.