Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website for Home Depot Canada not rendering correctly

  • 3 replies
  • 1 has this problem
  • 246 views
  • Last reply by FredMcD

more options

For the last few weeks the Home Depot Canada site is rendered incorrectly with lots of extraneous code being displayed. If I go to this sample link:

https://www.homedepot.ca/product/tremclad-rust-reformer-340-g-aerosol-spray-paint/1000140398

What I see looks like this (same image is attached below):

http://i1.imgrr.com/17s/5043_hdfirefox.JPG

All other pages from that site behave in a similar way with Firefox, making it unusable. Other browsers handle the website without a problem. Since Firefox is my primary browser this is a pain. Any assistance appreciated. Thanks.

For the last few weeks the Home Depot Canada site is rendered incorrectly with lots of extraneous code being displayed. If I go to this sample link: https://www.homedepot.ca/product/tremclad-rust-reformer-340-g-aerosol-spray-paint/1000140398 What I see looks like this (same image is attached below): http://i1.imgrr.com/17s/5043_hdfirefox.JPG All other pages from that site behave in a similar way with Firefox, making it unusable. Other browsers handle the website without a problem. Since Firefox is my primary browser this is a pain. Any assistance appreciated. Thanks.
Attached screenshots

Chosen solution

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

The settings already allowed sites to choose their own fonts so that didn't apply. But the tip to disable hardware acceleration seemed to fix things. Thanks!

more options

Glad to help. Safe Surfing.