Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube dropped frames while using AVC1 on Firefox

  • 6 replies
  • 1 has this problem
  • 1145 views
  • Last reply by matheo99

more options

Hello. I ve got a big problem on my Firefox browser. When im using other browsers i dont have this problem, it s only on Firefox, but i love using Firefox and i want to fix it.

Problem which i have shows up on youtube and sometimes on twitch. When im watching youtube video in vp09 format there are absolutely no problems with frames but when a video is in avc1 format - boom i cant watch it because of super frame drops - like a 90% of total frames are dropeed.

Example video: https://www.youtube.com/watch?v=xr-zCc9VUto

My pc is not the best but not the worst, i dont think its hardware problem because as i said, on other browser i dont have this problem watching the same video it isnt dropping frames. CPU: Xeon X5450 GPU: GTX 660Ti RAM: 8GB

This problem is with me since about a year, i dont know when it happened. Please help me, how to fix it?

Attached screenshots

Chosen solution

TyDraniu said

I mean that it shouldn't be Basic in the first line. You don't use GPU and performance is very weak.

Okay i fixed it by enabling OpenGL - changing layers.acceleration.force-enabled in about:config to true. It seems to be working properly now but i dont know why couldnt you just say that and help me fix this problem instead of saying "everything is messed up" lol it was only 1 rule to change and now everything s working

Read this answer in context 👍 0

All Replies (6)

more options

Can you enter about:support in the URL bar and paste here the Graphics section?

more options

TyDraniu said

Can you enter about:support in the URL bar and paste here the Graphics section?

Here you go

more options

Oh crap... everything is messed up.

more options

TyDraniu said

Oh crap... everything is messed up.

What do you mean?

more options

I mean that it shouldn't be Basic in the first line. You don't use GPU and performance is very weak.

more options

Chosen Solution

TyDraniu said

I mean that it shouldn't be Basic in the first line. You don't use GPU and performance is very weak.

Okay i fixed it by enabling OpenGL - changing layers.acceleration.force-enabled in about:config to true. It seems to be working properly now but i dont know why couldnt you just say that and help me fix this problem instead of saying "everything is messed up" lol it was only 1 rule to change and now everything s working

Modified by matheo99