Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot Log into Yahoo mail on Firefox

  • 3 replies
  • 1 has this problem
  • 36 views
  • Last reply by jscher2000

more options

I got an automatic update from Opera that I did not ask for, so all of my logins were lost. After recovering them and signing in, when I closed Opera, all of my freaking logins were gone again. There is no way to stop this from happening, because Opera likes to make it difficult to stop auto-updates and to stop passwords/usernames from being wiped out when closing Opera. OK, fine. I'll go back to Firefox, then.

So when trying to login to my Yahoo mail account on Firefox there is a challenge page that sends a verification code to my Android phone. I clicked yes, but there is no place to put the verification from the challenge page. When I go back to the Yahoo mail login page, it goes back to the challenge page again, sending a verification to my Android again. This does not happen in Opera, but there is still the issue of being kicked out of all of my social media, email accounts every freaking time.

I have WORK to do and am not interested in being a coder. I am a writer. So how can I stop this from happening? I would like to go on with my freaking life!

Below is a screen-cap of the challenge screen. Do you see any way to get past it? NO! the only thing that is possible is to get to the goddamn Help screen. I don't want any Help. I want to log into my Yahoo mail. Again, this is not happening in Opera, but Opera keeps kicking me out of my logins.

Attached screenshots

All Replies (3)

more options

Hi walford2, is this on Windows?

I'm a little puzzled by your screenshot because it is very plain looking. Did the previous screens have the standard Yahoo! styling (example screenshot attached)?

I suspect something is being blocked and breaking the page, but it's hard to say what it might be.

Q: Have you modified fonts or colors on the Options page?


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Windows 7 Pro 12GB RAM, Intel i5 3.33GHz [used to have Win10, but that is a virus] I haven't modified anything. I clear cache, temp files [not cookies, because that will delete my passwords/profiles], check registry, clear faults, then defrag/optimize disks every night at shutdown.

I didn't change anything.

That screen-cap showed what was going on. I selected "choose other options" and tried to select send a SMS to my, but the tick boxes were hidden, so I clicked around in empty space to select it. Finally I got the code to my phone and entered it into the Yahoo challenge page. Now I'm in, but if I try to use my preferred https://mail.yahoo.com/b/folders/1/ version, it displays as if it were a Win95 page. I had to 'upgrade to the /d/ version to get it to work.

Guess I'll have to live with that, because Opera 70 is unusable. Thank you for your effort, but I managed to force it to work for now myself. Given what I went through with Opera, certainly am NOT going to take the latest Firefox update.

[resuming my life after 3 1/2 hours of needless struggle and aggravation]

more options

Your experience is not how Firefox normally displays Yahoo. I've attached a screenshot of a similar "enter a code" screen which has full normal styling.

If you want to work on why your Firefox is not displaying sites normally, you could return to this thread or start a new one. I'll mention two things to check on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section.

Fonts

Click the "Advanced" button. Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Click OK to close the dialog.

Colors

Click the "Colors" button. Try changing this setting:

"Override the colors specified by the page with your selections above"

The default value is "Only with High Contrast themes". Try changing that to "Never".

Click OK to close the dialog.

Any improvement?