Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Strange Results on https://www.chase.com/

  • 12 replies
  • 1 has this problem
  • 30 views
  • Last reply by whitedavidp

more options

Hello and thanks in advance for any help you can give me.

For many years, I have had trouble with the rendering of https://www.chase.com/ in my Win10 Firefox install (see attached). This does NOT happen in my wife's install. I have been a user for a long, long time and this has persisted even through the update to 79.0 today. On the same machine, it renders fine in Chrome (see other attached).

As I said, the problem does not happen on my wife's computer and since it works in Chrome on the same computer I know this must be something wrong with my Firefox install. I have tried running with --safe-mode and the problem persists. I have repeatedly cleared site data/cookies and even the entire Firefox cache. The problem persists.

While I suspect there is still something hanging around in my profile that is causing this, I don't know what it is and I am loathe to erase my entire profile and start anew.

Any suggestions on how to get to the bottom of this mystery?

Thanks

Attached screenshots

Chosen solution

Could you check this group of settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste referer and pause while the list is filtered

Firefox should display about eleven preferences. This article describes many of them: https://wiki.mozilla.org/Security/Referrer

Have you customized any of these? I can replicate your broken site display by setting the first one on that page, network.http.sendRefererHeader to either 0 or 1. Neither of those values allows Firefox to tell Chase that the request for its script was generated from a page on Chase, it just looks like a disconnected request. And therefore Chase terminates the connection instead of sending the script.

Read this answer in context 👍 0

All Replies (12)

more options

Hi, it definitely looks like Firefox is not applying the style sheet that transforms the bare HTML into the site you recognize. Let's see whether we can figure out why not.

Chase's home page loads style sheets from two different servers:

(1) Same site

Can your Firefox load this URL?

https://www.chase.com/c/062020/etc/designs/chase-ux/css/home.min.css

The expected result is a wall of text starting with

/* normalize.css v3.0.1 | MIT License | git.io/normalize */

Does the page load, or is there an error, or is it unreadable?

(2) Chase CDN

Can your Firefox load this URL?

https://static.chasecdn.com/web/2020.06.21-643/logonbox/assets/logonbox.css

The expected result is a wall of text starting with

body,html{height:100%}.jpui.button,.jpui.checkbox:not(.disabled) [role=checkbox],

Does the page load, or is there an error, or is it unreadable?

Note: the forum has a link spam filter, so if you quote a URL in your reply, it won't appear immediately while it passes through the moderation queue.

Helpful?

more options

Hi and thanks for your help. FF seems to get those urls just fine and the seem ok (although jibberish to me).

I have managed, through trial and error to see that there seems to be something in my prefs.js file that is causing this unpleasant behavior. I know this because:

(a) I created a new test profile and chase.com loads fine there.

(b) I shut down FF, renamed prefs.js to prefs.js.orig, and restarted. In the resulting session, chase.com loads fine.

I have been using FF for decades now and my prefs.js (and therefore about:config) is littered with all sorts of stuff from extensions that cannot work in the current FF and have long been uninstalled, printer setup information for printers I no longer own, etc.

But just after doing (b) above, FF cannot be returned to its pre-(b) state by exiting and renaming prefs.js back, and restarting. I cannot say exactly what is wrong. But it does not startup the same. I have been able to get things back to where they were by restoring last night's backup of the profile folder. So it seems that fiddling the prefs.js file is really not supported any more. In earlier FF I could fiddle it without problems.

So I know a bit more. But have made no real progress.

Thanks!

Helpful?

more options

New profile test is always a good reality check.

The prefs.js file has tons of stuff in it, some related to changes you made, and some related to data recorded by Firefox as it maintains itself. If you want to delete a line here or there (with Firefox closed), that probably is fine, but it's a good idea to research the specific preferences before doing that.

It's difficult to know where to start on spotting a culprit. Could you try looking at Firefox's Developer Tools panel, Web Console and Network Monitor? Here's where I suggest starting:

You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Click the trash can icon to clear any existing messages, then reload the page bypassing the cache (for example Ctrl+F5 or Ctrl+Shift+r). Are there any messages about things that couldn't be loaded or were blocked?

Switch to the Network panel to see the list of file Firefox loaded into the page. The usual status is "200" (meaning success). A 301 or 302 is a redirect, which is fine. Are there any with a blank status or higher status code?

Some reading if you're interested:

Helpful?

more options

Hello again and thanks!

When loading chase.com, I see the following in the web console. I suppose that the missing .js could be a significant problem... They are not shown in the web console when I start FF using a new testing profile.

Cheers

Cookie “TS01afb5d0” will be soon rejected because it has the “sameSite” attribute set to “none” or an invalid value, without the “secure” attribute. To know more about the “sameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite www.chase.com Loading failed for the <script> with source “https://www.chase.com/c/062020/etc/designs/chase-ux/clientlibs/jquery/js/jquery.min.js”. www.chase.com:36:1 Loading failed for the <script> with source “https://www.chase.com/c/062020/etc/designs/chase-ux/clientlibs/require/js/require.min.js”. www.chase.com:37:1 Loading failed for the <script> with source “https://www.chase.com/c/062020/apps/chase/clientlibs/foundation/scripts/Reporting.js”. www.chase.com:45:1 Uncaught ReferenceError: requirejs is not defined

   <anonymous> https://www.chase.com/:53

www.chase.com:53:19 Loading failed for the <script> with source “https://www.chase.com/c/062020/etc/designs/chase-ux/clientlibs/chase-ux/js/dist/index.min.js”. www.chase.com:68:1 Uncaught ReferenceError: require is not defined

   <anonymous> https://www.chase.com/:71

www.chase.com:71:7 Uncaught ReferenceError: require is not defined

   <anonymous> https://www.chase.com/:81

www.chase.com:81:11 Uncaught ReferenceError: require is not defined

   <anonymous> https://www.chase.com/:194

www.chase.com:194:5 Uncaught ReferenceError: require is not defined

   <anonymous> https://www.chase.com/:601

www.chase.com:601:31 Uncaught ReferenceError: CHASE is not defined

   <anonymous> https://www.chase.com/:48
   EventListener.handleEvent* https://www.chase.com/:48

www.chase.com:48:69

Helpful?

more options

You created another thread about cleaning out prefs.js that seem to be related to the issues you reported here.

Which of these two threads do you prefer to discus about prefs.js to avoid duplicate answers ?

Helpful?

more options

I don't think Firefox normally would block external script files from the same server. And JavaScript is not completely disabled -- the site displays a message for that situation.

Do you run any extensions that could be blocking those files?

Helpful?

more options

Thanks again. I have tried running in safe-mode, which should - I think - disable all extensions. And the problem persists. Yet, in a whole new profile it renders fine. And if I just rename prefs.js it renders just fine in my normal profile. Not sure how/what could be in there that causes this.

Helpful?

more options

And sorry about what might be considered a cross-post. It wasn't really my intention to have this thread wander that way. Thanks

Helpful?

more options

Chosen Solution

Could you check this group of settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste referer and pause while the list is filtered

Firefox should display about eleven preferences. This article describes many of them: https://wiki.mozilla.org/Security/Referrer

Have you customized any of these? I can replicate your broken site display by setting the first one on that page, network.http.sendRefererHeader to either 0 or 1. Neither of those values allows Firefox to tell Chase that the request for its script was generated from a page on Chase, it just looks like a disconnected request. And therefore Chase terminates the connection instead of sending the script.

Helpful?

more options

Oh my. That was it. So it was something in the prefs.js after all. I sure would never have seen this or even knew what it was for/about. It was set to 1 instead of the default of 2. I wonder how it got changed? No idea. I cannot thank you enough as this was a pain and the main reason I have had to keep Chrome on my machine. Cheers!

Helpful?

more options

I'm sure we all have a lot of settings carried forward from earlier times that either someone recommended or an extension changed, but no longer can explain.

Helpful?

more options

Well thank you so much for helping me get to the bottom of all this nonsense. I was also able to remove a somewhat large pile of old stuff from my profile and prefs.js. Your help is very much appreciated.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.