Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

start up laptop loading browser

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by jscher2000

more options

Whenever I start my laptop on which firefox is my browser it also loads ebay, markplaats, bing, google, wikipedia. I do not want this crap to start when I start my laptop/open my browser. I have ccleaner and in that program there is the option to prevent forementionded programmes to start, but when I have closed my laptop and restart it (lets say the next morning) al those programmes boot up again. How do I remove or prevent for ever that those programmes start?

All Replies (3)

more options

Do you mean Firefox opens a tab for each of those sites when you start it up? Here are four ways Firefox might be set to open multiple tabs at startup:

(1) Custom URLs list for the Home Page setting

More info on modifying your setting: How to set the home page

(2) Pinned tabs

More info on how to unpin those tabs: Pinned Tabs - keep favorite websites open and just a click away

(3) An add-on

I'm not aware of any add-on that does this, but you could try starting in Firefox's Safe Mode as a test. More on that after this list.

(4) Modified Firefox shortcut

If URLs are added to the command line of your Firefox shortcut, Firefox will open those URLs when you use the shortcut.

Safe Mode Test

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

student149190 said

I have ccleaner and in that program there is the option to prevent forementionded programmes to start

Does CCleaner explain what setting causes it?

Helpful?

more options

If this is about the default search engines -- these are packaged as extensions, so CCleaner thinks they are add-ons even though they are built-in -- do you want to get rid of all those search engines?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.