Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opening a new browser/window

more options

Firefox opening a new browser/window jscher2000 Jul 27, 2020, 1:44:29 AM

Hi Irv, you definitely have multiple Firefox profiles, but what I wonder is whether you might have multiple installations of Firefox. In each of the different windows, could you call up the Troubleshooting Information page. Either:

   "3-bar" menu button > "?" Help > Troubleshooting Information
   (menu bar) Help > Troubleshooting Information
   type or paste about:support in the address bar and press Enter 

In the first table on the page, please compare: (1) Application Binary row Where is your main installation and where is the other one? For example:

   Current 64-bit program folder: C:\Program Files\Mozilla Firefox\firefox.exe
   Legacy 32-bit program folder: C:\Program Files (x86)\Mozilla Firefox\firefox.exe 

Do you have multiple installations? (2) Profile Folder row The part after the last . is the most interesting part. Please make a note of the name of your main profile for future reference.

First, thank you for your response. Second, I have attached jpegs from each of the Troubleshooting pages and a word doc of the lines that were asked in them. The profile I want to keep, of course, is the one from the taskbar. Now do I just delete the profile of the desktop icon for its location to get rid of it?

Thanks again for the assistance, Irv

Attached screenshots

All Replies (4)

more options

Hi Irv, it seems that during an update or due to some other event, instead of the Firefox installer re-using the legacy folder

C:\Program Files (x86)\Mozilla Firefox [NEED TO SAVE]

it installed into the 64-bit folder:

C:\Program Files\Mozilla Firefox [CAN DELETE]

Before we remove the newer installation, please switch your system default browser to Internet Explorer 11. This avoids a problem with Microsoft Office where removing the program folder of its preferred browser renders it unable to open links.

Then try hiding the unwanted Firefox installation by doing a rename. First exit all your Firefoxes.

Then with Windows Explorer showing the contents of

C:\Program Files

right-click Mozilla Firefox and Rename to OldFirefox

Then remove the unwanted desktop shortcut.

Does your Taskbar icon still work normally? If so, great. If not, reverse the rename.

The next step is to switch your system default browser back to Firefox. Could you try using Firefox's own built-in feature for this. It's on the Options page, General panel.

So far so good?

more options

By the way, I think there is some other difference between these two 64-bit Firefoxes. Maybe they are different "languages" or "locales"? At the bottom of the Troubleshooting Information page, there is a section on that. The one you don't want is, I think the U.S. English build. Is the other one a different language/locale?

more options


I did the first part of making IE 11 the default browser and renaming the Mozilla Firefox Folder. All that worked fine. The taskbar icon works.

But, I went out of order. I did the above before I saw your "by the way" message. I am again attaching jpegs from both troubleshooting pages on the Internationalization & Localization section.

If this is what you are referring to they are both the same.

So, if this is alright I will go back and redo the first part of making IE 11 the default browser, renaming the Mozilla Firefox Folder and do all that. After I delete C:\Program Files\Mozilla Firefox is there anything else that needs deleting?

I am also attaching a jpeg of the Mozilla Firefox program from the Control Panel - Programs_Features.

Thanks again and again for all your assistance, Irv

more options

irn89 said

After I delete C:\Program Files\Mozilla Firefox is there anything else that needs deleting?

Hi Irv, you also have the option to deleting the extra profile from the about:profiles page. However, no rush.