Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

language options

  • 11 replies
  • 1 has this problem
  • 163 views
  • Last reply by claude25

more options

I added the language/spell check to my work email (outlook.office). I follow the same procedure in my hotmail (outlook.live) and although I added them, it is not an option when I type a message. I use Firefox as a browser and cleaned the cache. Elizabeth

Chosen solution

Hi Elizabeth, sorry for omitting the context. I was commenting on your second screenshot. That is the context menu shown when (non-editable) text is selected in the page -- it has far fewer actions than the regular menu. I suggested actions to try to get the regular menu back by deselecting whatever is selected. Is there really nothing selected -- Firefox is just very confused?

Read this answer in context 👍 0

All Replies (11)

more options

Hi Elizabeth, I'm not sure who is in charge of spell-checking in the mail editor. Firefox will use its own dictionaries, so if Firefox is adding the squiggly markings, you may also need to add dictionaries to Firefox. More info in this article: How do I use the Firefox spell checker? (the part about adding dictionaries; note: don't add a full language pack).

more options

I had it already working, added the languages and the dictionaries. I right clicked on the mouse and chose the language I was using and it did a quite a good spell check. It stopped working!!! When I right click now, languages and spell check is not an option. It still works on my outlook.office account. as I matter of fact, it works on this website too... but what I get in hotmail.live is different

Elizabeth

more options

Hi Elizabeth, for some reason you are getting a selection context menu instead of the standard one. I'm not sure what is causing that if you cannot see any text being selected.

Possibly you used Find (Ctrl+f) and Firefox still has a found word selected somewhere on the page away from the editor itself? If any kind of Find bar is open, try clicking in the find box and pressing the Esc key to cancel the search.

more options

I guess I am poor in my explanation. Although I had the option of changing languages when writing a text, with a right click of the mouse, now it does not show that option. It is still an option in my work email (outlook.office, see first screenshot) but not in my hotmail account (outlook.live, second screen shot) BUT IT WAS AN OPTION BEFORE. I assume in some updating something was changed? Is there something I need to toggle? Elizabeth

more options

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Language and Appearance: "Check your spelling as you type"

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

more options

that is my problem: there is no "language" sub menu... There used to be and now it is not an option. elizabeth

more options

Chosen Solution

Hi Elizabeth, sorry for omitting the context. I was commenting on your second screenshot. That is the context menu shown when (non-editable) text is selected in the page -- it has far fewer actions than the regular menu. I suggested actions to try to get the regular menu back by deselecting whatever is selected. Is there really nothing selected -- Firefox is just very confused?

more options

you are a genius... I started looking at the text and left clicking (!) I found a drop down menu where I chose "editor" and it gave me the first screenshot, with the option of "language" Several hours later, all is well. Thank you.

more options

Well, the issue is limited to the Outlook email body text area. In the case of the subject line, right clicking does provide a Check Spelling and a Languages submenu. But not in the main body text area.

more options

A webpage can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker. You can right-click in the text area or input field and use "Inspect Element" to check in the Inspector if this text area has a spellcheck="false" attribute. You can Remove this spellcheck="false" attribute or change it to spellcheck="true" via a double-click or via "Edit As HTML" to make the "Check Spelling" item in the right-click context menu reappear. Firefox will disable "Check Spelling" in the right-click context menu of a text area if the web page disables the spelling checker via a spellcheck="false" attribute of this element.


more options

Well, turns out that MS is indeed forcing outlook to use its builtin spell checker, which only supports 1 language. Indeed, spellcheck is set to false. for the email body text area.

But, it is possible to turn off spell check (proofing) by going to Settings/Mail/Compose and Reply/Microsoft Editor Settings where you can find a toggle switch for Spelling. After reloading the page, now, the textarea does not have the spellcheck attribute set to false and finally Firefox takes over. Ouf...