Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can not send mail after update ver78 SOLVED: caused by TLS

  • 21 replies
  • 12 have this problem
  • 12861 views
  • Last reply by ljs23

more options

I can not send emails after the new update I am getting this error. Sending of the message failed. Peer using unsupported version of security protocol. The configuration related to smtp.vcn.com must be corrected I have checked all settings and had the ISP check also and can not get past this error.Any help would be appreciated

Modified by Wayne Mery

Chosen solution

I think this could be due to the minimum version of TLS supported by TB 78. The release notes state that versions lower than 1.2 are disabled, so if your server only supports v. 1.1, you might be able to fix sending by changing the preference security.tls.version.min to 2 from the default 3, in Config. editor.

http://kb.mozillazine.org/Security.tls.version.*

Read this answer in context 👍 4

All Replies (20)

more options

Chosen Solution

I think this could be due to the minimum version of TLS supported by TB 78. The release notes state that versions lower than 1.2 are disabled, so if your server only supports v. 1.1, you might be able to fix sending by changing the preference security.tls.version.min to 2 from the default 3, in Config. editor.

http://kb.mozillazine.org/Security.tls.version.*

Modified by sfhowes

Helpful?

more options

Try to change in THUNDERBIRD preferences editor security.tls.version.min from 3 to 1

From the menu at the top right, go to Options. Scroll all the way to the bottom and click on Config Editor. Skip past the warning. Scroll down until you find security.tls.version.min (or paste security.tls.version.min to upper frame) Double click on it, and set the value to 1

Mozilla disabled TLS 1.0 and 1.1 in the latest versions of Firefox and Thunderbird. Thunderbird 73b and above. This causes issues with anyone connecting via SSL/TLS/StartTLS to services uses 1.1.

Helpful?

more options

Dear Thunderbird team,

I received similar warning. I have gone through my account's settings and have not yet found the word "Peer" anywhere. I have not yet found "security protocol" from account's settings either.

Luckily I have an old computer with old operating system and old version of Thunderbird that I hope you won't update without my consent, like you did here. I can still access my account using the old version of Thunderbird, and through my up-to-date Android Gmail application (no, it is not a gmail account).

So — dear Thunderbird team — Do you really think the warning given by Thunderbird was helpful? Should I really have known what to do? I'm just a user of Thunderbird application. Should I really "look under the bonnet" and tinker with the machinery following fellow user's advice to get me going again?

Note: I did not ask to be updated and you do not offer a button to go back.

"Most seriously displeased"!

Is it so that the Thunderbird team is inventing new things at a rate that nobody — even your help pages editors — cannot keep up with?

/pekka

Modified by -PSi-

Helpful?

more options

sfhowes said

I think this could be due to the minimum version of TLS supported by TB 78. The release notes state that versions lower than 1.2 are disabled, so if your server only supports v. 1.1, you might be able to fix sending by changing the preference security.tls.version.min to 2 from the default 3, in Config. editor. http://kb.mozillazine.org/Security.tls.version.*

In my case TB v78.2.2, the server does support TLSv1.2, so security.tls.version.min = 3 should work. However, I had to set security.tls.version.enable-deprecated = true, for sending mails to work.

Helpful?

more options

Thanks for your help, looks like I'm back in action!

Helpful?

more options

I had this same issue, where I had to set security.tls.version.min to 1 to fix.

Mozilla / Thunderbird really should give advance warning before doing something like this again in future, especially for non technical users. This could have been a simple pop-up to say that you connecting using a deprecated TLS protocol a month or two in advance, rather than suddenly blocking it out of the blue.

Helpful?

more options

Tried security.tls.version.min =2, no go. had to go to 1.

Helpful?

more options

Agree with editorsean. These guys really screwed up by not at least warning users. They had to know this was going to be a problem. Even though this a free email client it certainly is not good customer service. This should all be transparent to the user. I set my security.tls.version.min = 1 and set my security.tls.version.enable-deprecated = true and TB still does not function Inbound or Outgoing with my Earthlink ISP email servers. If anyone can help it would be appreciated (hello TB coders).

Helpful?

more options

I had to make both these changes to get incoming and outgoing mail to work.

security.tls.version.min = 1 security.tls.version.enable-deprecated = true

It does seem somewhat careless to release this upgrade (78.4) without some warning about TLS, although I have no idea how many users this might affect.

Helpful?

more options

Already followed these steps but still no incoming/outgoing mails.

security.tls.version.min = 1 security.tls.version.enable-deprecated = true

Any other solution?

Thanks.

Helpful?

more options

I have a MacOS Mojave (v10.14.6) machine, and recently upgraded Thunderbird from 68.12.1 to 78.4.0. I have 5 different IMAP accounts I access via Thunderbird. The 2 that are gmail "under the hood" are working fine. The 3 that are Earthlink are not, primarily with regards to receiving email rather than sending it.

I decided to try Earthlink support before messing around with TLS configs, and spent about 2 hours online with an Earthlink Support person who tried many things. He eventually got my accounts to work (receive new email & display contents of all received messages) in Thunderbird 78.4.0 by changing settings so that - For all accounts, the "Server Settings" Security and Authentication are Connection security = None, Authentication method = Password, transmitted insecurely - For all accounts, the "SMTP Server" Security and Authentication are Connection security = None, Authentication method = Password, transmitted insecurely

I could not get him to answer the question, "What TLS security standard do Earthlink email servers accept?". I also asked "Please, will you tell me if Earthlink email servers accept TLS 1.2?", to which he replied "It accept but in Thunderbird it is not accepting so there is no harm".

More details about my problem are at https://support.mozilla.org/en-US/questions/1310338

Helpful?

more options

ar_bheen said

Already followed these steps but still no incoming/outgoing mails. security.tls.version.min = 1 security.tls.version.enable-deprecated = true Any other solution? Thanks.

I have the same issue. In my computer, I'm using the TB 78.4.0 under Windows. I'm using TB through a socks5 proxy.

Without setting any stl.version option, IMAP of gmail works fine.

But even I set those settings: security.tls.version.min = 1 security.tls.version.enable-deprecated = true

I still can't send email through the SMTP of gmail.

Any ideas? Thanks.

Helpful?

more options

asmwarrior said

ar_bheen said

Already followed these steps but still no incoming/outgoing mails. security.tls.version.min = 1 security.tls.version.enable-deprecated = true Any other solution? Thanks.

I have the same issue. In my computer, I'm using the TB 78.4.0 under Windows. I'm using TB through a socks5 proxy.

Without setting any stl.version option, IMAP of gmail works fine.

But even I set those settings: security.tls.version.min = 1 security.tls.version.enable-deprecated = true

I still can't send email through the SMTP of gmail.

Any ideas? Thanks.

Is there any help we can get here? I really need my email to work now.

Helpful?

more options

If you are someone for whom TLS settings did not help, you should post a new topic https://support.mozilla.org/en-US/questions/new/thunderbird, and include in the topic title the words of the error you see, or thing(s) you have attempted that has not helped.

Helpful?

more options

If you are someone for whom TLS settings did help...

Be sure to inform your mail provider that they are many years behind in supporting proper security for their customers - TLS 1.1 and 1.0 considered by the industry to be unsafe https://www.venafi.com/blog/why-its-dangerous-use-outdated-tls-security-protocols, and TLS 1.2 emerged ten years ago.

Helpful?

more options

Since I already followed the following steps that I found on this forum and other related topics and still I don't have the incoming and outgoing mails.

Steps: security.tls.version.min = 1 security.tls.version.enable-deprecated = true

I decided to downgrade it back to a working version - 68.11.0 is the previous version I found with downloadable .exe.

https://www.filepuma.com/download/mozilla_thunderbird_64bit_68.11.0-26478/

Now I was able to have my incoming and outgoing mails working.

Don't forget to back-up your mail and and disable the auto-update.

Hope this helps.

Helpful?

more options

Since I already followed the following steps:

security.tls.version.min = 1 security.tls.version.enable-deprecated = true

And still I don't have the incoming and outgoing mail.

I decided to downgrade it back to working version that I have (this is the only downloadable version I got - https://www.filepuma.com/download/mozilla_thunderbird_64bit_68.11.0-26478/)

Procedure:

1. Back-up exisiting email 2. Uninstall the existing TB 78.4 3. Restart 4. Install the TB 68.11.0 5. Create New Account 6. Change directory on the back-up mail 7. Disable automatic update

Now I have working incoming and outgoing mail.

Hope it helps.

Thanks.

Helpful?

more options

If you have access to your email server that runs on postfix you can fix this easy by adding TLSv1.2 into postfix main.cf file as it follows:

smtpd_tls_mandatory_protocols=!SSLv2,!SSLv3,TLSv1,TLSv1.2 smtp_tls_mandatory_protocols=!SSLv2,!SSLv3,TLSv1,TLSv1.2 smtpd_tls_protocols=!SSLv2,!SSLv3,TLSv1,TLSv1.2 smtp_tls_protocols=!SSLv2,!SSLv3,TLSv1,TLSv1.2

Note that server certificates are not optional in TLS 1.3. To run without certificates you'd have to disable the TLS 1.3 protocol by adding "!TLSv1.3" (without quotes) in the lines above.

Helpful?

more options

No, it did not work so still no emails except on my server. I notice there are many of us with the same problem. What to do for all of us?

Helpful?

more options

Thank you all, very useul, it worked !

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.