Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I do not was Search with Amazon.com, I want Amazon.com

more options

A while back a change occurred where, when I use my top sites, whether it be through the drop down address bar, or a new tab, Amazon.com has been replaced with Search with Amazon.com. This does nothing for me.

I usually visit Amazon.com without the intention of searching for anything immediately, so now , when selecting this choice, instead of taking me to Amazon.com, i get sent to an address bar with @amazon on it. Which wouldn't be terrible, if hitting enter would at least take me to amazon.com, but no, hitting enter does nothing.

It has made this shortcut useless to me, and often infuriating.

I have yet to ind a way to change this.

All Replies (3)

more options

Do you have this search engine pinned to the Firefox Home page ?

You can disable search engines via the "Options/Preferences -> Search" panel.


The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions.

You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites
  • Options/Preferences -> Search -> Search Suggestions

Helpful?

more options

My problem is, wherever I had Amazon.com as a top site, it has been replaced with this

Helpful?

more options

The problem is, every instance I originally had of Amazon.com, got replaced with this (see image)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.